The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable Service Checks

Discussion in 'General Discussion' started by vexil, Feb 11, 2009.

  1. vexil

    vexil Member

    Joined:
    Apr 16, 2006
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I recently uninstalled postgres using RPM, but it was installed by cPanel. Now Cpanel is sending me an email every 5 minutes:
    ----
    postgresql failed @ Thu Feb 12 07:14:48 2009. A restart was attempted automagically.
    Service Check Method: [check command]

    Cmd Service Check Raw Output: postmaster is not running
    ---------

    How do I disable the service check? Or how do I tell cPanel not to monitor it?

    Or, at least, how do I stop these extra 480 emails from landing in my inbox every day?

    Thanks for your help.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Open WHM, in the top left search area type in Service.

    Find Service Manager in result and click it, then untick the options for:

    postgresql
    PostgreSQL Database Server

    I think that would do it. ;)
     
  3. vexil

    vexil Member

    Joined:
    Apr 16, 2006
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    postgresql not listed in service manager

    Thanks for your reply. That was actually the first thing I checked as it's the most obvious. But postgresql is not listed there. cPanel obviously knows it's not installed, but yet still sends the emails...
     
  4. JPC-Stefan

    JPC-Stefan Member

    Joined:
    Oct 29, 2008
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    You can also check the chksrvd configuration file "/etc/chkserv.d/chkservd.conf" to find out if postgresql is enabled or disabled in it.
     
  5. kistler

    kistler Well-Known Member

    Joined:
    Jan 27, 2005
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    16
    I am having the a similar issue only with MySQL... mine is still installed but when I disable monitoring within WHM it still restarts it. I have been unable to stop it from starting up every 5min.. any help?

    my chkservd.conf

    Code:
    clamd:1
    cpdavd:1
    cpsrvd:1
    entropychat:0
    exim:1
    exim-26:1
    exim-altport:1
    ftpd:1
    httpd:1
    imap:1
    ipaliases:1
    lfd:1
    melange:0
    named:1
    pop:1
    spamd:1
    sshd:1
    syslogd:1
    
     
Loading...

Share This Page