Disable spamassasin globally via shell.

soumya.tr

Member
Oct 24, 2009
23
0
51
Hi,

I have to disable spamassasine globally in many cpanel servers. I followed the below given steps:

1. Removed file /etc/global_spamassassin_enable [this itself sets the option '"WHM >> exim configuration editor >>
SpamAssassin™: Forced Global ON [?]{Turn on SpamAssassin™ for all accounts (i.e. with no option to disable)}' to OFF.

2. Changed the parameter globalspamassassin to 0 in /etc/exim.conf.localopts.

Is these steps fine? Should I have to do any other step [like rebuilding eximconf using /scripts/buildeximconf or restarting service exim ]?

Thanks in advance.
 

arvin_webzias

Registered
Aug 29, 2012
4
0
1
Neyattinkara, Kerala, India, India
cPanel Access Level
Root Administrator
You can disable SpamAssassin for your entire server by following the below steps:

[1] Login to your WHM.
[2] Go to Tweak Settings.
[3] Uncheck SpamAssassin Spam Filter option and save it.

If you are not using SpamAssassin in your server, you can also disable SpamAssassin service. To disable it:

[1] In WHM -> Go to Service Manager.
[2] Uncheck Enabled and Monitor option for spamd.

Regards
 

soumya.tr

Member
Oct 24, 2009
23
0
51
@arvin_webzias : Thanks.

But is there any way to do this via shell? As I have the change to be made in a lot of servers, and was planning to do via a shell script.