The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable Tomcat and Java for optimization

Discussion in 'Workarounds and Optimization' started by maruk, Mar 25, 2011.

  1. maruk

    maruk Member

    Joined:
    Mar 25, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hi guys,

    i have cpanel and i loaded 2 websites: a wordpress blog and a mybb forum.

    i noticed that tomcat load memory and i see 2 processes:

    tomcat 11529 0.0 5.4 666764 56348 ? Sl Mar24 0:06 jsvc.exec -user tomcat -cp ./bootstrap.jar -Djava.endorsed.dirs=../common/endorsed -outfile

    rms7 11644 0.0 7.7 559444 79184 ? Sl Mar24 0:09 /usr/local/jdk/bin/java -Dpython.home=lib -Dred5.root=/usr/local/RMS_7.0 -Dlogback.ContextSe

    I would like to disable them because i don't need java or tomcat

    I disabled tomcat via whm but i still see this processes respawning even if i kill them.

    I searched through the forum but i didn't find a clear solution

    Can you point me to the right direction?

    Thank you

    LT
     
  2. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
  3. maruk

    maruk Member

    Joined:
    Mar 25, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Thank you cPtechie
     
  4. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hey!

    You are entirely welcome ! Cheers!
     
  5. maruk

    maruk Member

    Joined:
    Mar 25, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Just an info. Why if i disable Tomcat from the WHM i still see those processes running?
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please define how it was disabled in WHM, since there are various ways someone might consider it disabled when it isn't actually. Once we have the step-by-step details on what action(s) were performed, I can try to answer the question.
     
  7. maruk

    maruk Member

    Joined:
    Mar 25, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I have disabled Tomcat JSP Server in WHM > Service configuration > Service manager (all 2 boxes)

    Thank you
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Did you also remove it by recompiling EasyApache on the machine to uncheck Tomcat in Step 5 Apache's Short Options list? It might be required to do that as well.

    I do agree that it should have stopped the services upon unchecking them in Service Manager area for enabled.
     
  9. maruk

    maruk Member

    Joined:
    Mar 25, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    No i didn't recompile Apache because i don't know how to do it.

    I will try to disable the service as suggested in the previous post, do you think is suitable?

    Thank you
     
  10. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I agree with the link provided to disable tomcat other than this section:

    You shouldn't be editing httpd.conf directly. Recompile it to uncheck Tomcat as I suggested to get anything to do with Tomcat out of Apache's configuration, so just /scripts/easyapache or WHM > EasyApache (Apache Update) and in Step 5 for the Short Options, uncheck Tomcat, then choose to rebuild and save.
     
  11. maruk

    maruk Member

    Joined:
    Mar 25, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ok thank you very much
     
Loading...

Share This Page