The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disabled "Nobody" from sending yet it can still send???

Discussion in 'E-mail Discussions' started by mguindon10, Aug 17, 2007.

  1. mguindon10

    mguindon10 Active Member

    Joined:
    Aug 23, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Detroit, MI.
    In the tweak settings I have a check in the box for:
    "Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)"

    Yet I have a php mail script that runs and is sending as nobody instead of the user. And yes I do have Suexec enabled and running. Any ideas???
     
  2. lbeachmike

    lbeachmike Well-Known Member

    Joined:
    Dec 27, 2001
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Beach, NY
    cPanel Access Level:
    Root Administrator
    Do you have PHPSUexec enabled in your Apache build?

    I'm looking to resolve the same issue on my server and have not yet confirmed, but I believe this is the solution.

    Mike
     
  3. mambovince

    mambovince Well-Known Member

    Joined:
    Jan 15, 2005
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    London, UK
    This must be one of the most annoying things for me.
    Unfortunately, using PHPSUexec is not an option for most hosted clients.

    Wish we could force all scripts to send via smtp instead of nobody.
    Until then, the spammers will keep creating havoc.:(

    - Vince
     
  4. mguindon10

    mguindon10 Active Member

    Joined:
    Aug 23, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Detroit, MI.
    Yes last time I compiled it I installed security mod and made sure that was there. I could be mistaken though. I'll check and let you know.
     
Loading...

Share This Page