The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disabling antirelayd

Discussion in 'General Discussion' started by anup123, Aug 29, 2008.

  1. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Antirelayd cannot be disabled:

    Here's the result from ssh:

    tailwatchd --disable=Cpanel::TailWatch::Antirelayd

    gives:
    [/usr/local/cpanel/bin/tailwatchd]: Invalid arguments
    [/usr/local/cpanel/bin/tailwatchd]: safeunlock: Invalid arguments
    [/usr/local/cpanel/bin/tailwatchd]: Invalid arguments
    [/usr/local/cpanel/bin/tailwatchd]: safeunlock: Invalid arguments
    Cpanel::TailWatch::Antirelayd could not be disabled

    From WHM just one line -- Cannot be disabled.

    WHM 11.23.2 cPanel 11.23.6-R26881

    So how does one disable POP before SMTP?

    TIA
    Anup
     
  2. RickG

    RickG Well-Known Member

    Joined:
    Feb 28, 2005
    Messages:
    238
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    North Carolina
    I would try ...

    1) Placing a blank file called antirelayddisable in the /etc/ directory.

    2) Make certain both /etc/relayhosts and /etc/relayhostsusers are empty.

    3) Restart Exim.
     
  3. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Thanks that worked.
    However i find that these steps have to be rerpeated everytime antirelayd is switched on. Just a minor quirk which i think cPanel would iron out in upcoming releases.

    Thanks
    Anup
     
Loading...

Share This Page