Naveen Guleria

Registered
Jun 16, 2017
1
0
1
INDIA
cPanel Access Level
Root Administrator
Hello sir,
I need to enable autossl Letsencrypt for all users, old and new in cpanel/whm.

Now i have created a feature list, added feature list to a package and create a user account with that package. Now in cpanel of that user there is no icon for Letsenrypt SSL but in SSl/TLS status > i can see the Letsencrypt cert installed for the domain. Is it normal. Is there any icon missing for letsencrypt?

Also when i try to disable the autoSSL in Manage AutoSSL > Manage Users > Disable AutoSSL for this user. It still showing the letsencrypt cert installed in the user domain. Am i doing something wrong and yes i have cleared the cache and tested the setting on different PCs.
Thanks,
Best Regards.
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello @Naveen Guleria,

I've moved this post to it's own thread.

Now i have created a feature list, added feature list to a package and create a user account with that package. Now in cpanel of that user there is no icon for Letsenrypt SSL but in SSl/TLS status > i can see the Letsencrypt cert installed for the domain. Is it normal. Is there any icon missing for letsencrypt?
This is normal. There's no end-user interface for AutoSSL in cPanel, but you can follow the progress of the existing feature request at:

AutoSSL cPanel interface for end user control

Also when i try to disable the autoSSL in Manage AutoSSL > Manage Users > Disable AutoSSL for this user. It still showing the letsencrypt cert installed in the user domain. Am i doing something wrong and yes i have cleared the cache and tested the setting on different PCs.
Disabling AutoSSL will prevent the generation of new certificates on the account, however it won't delete the existing ones. You can manually delete existing SSL certificates via "WHM >> Manage SSL Hosts".

Thank you.