The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disabling cppop automagical restart

Discussion in 'E-mail Discussions' started by IC3D, Mar 1, 2011.

  1. IC3D

    IC3D Registered

    Joined:
    Feb 16, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to stop and disable POP services on one of my WHM boxes all together. I have an internal app communicating via IMAP and SMTP but POP services for this box is unnecessary and will never be used, so I thought I would disable it.

    In - Main >> Service Configuration >> Mailserver Configuration
    I unset POP3D POP3DSSL

    Then I ran:

    /etc/init.d/cpanel stop
    touch /etc/cppopdisable
    /etc/init.d/cpanel start

    Now for the past 24hrs every 5mins I get an email:

    pop failed @ Tue Mar 1 10:42:42 2011. A restart was attempted automagically.
    Service Check Method: [tcp connect]
    Failure Reason: Unable to connect to port 110

    WHM 11.28.83
    CENTOS 5.5 x86_64

    How do I disable this from trying to restart every 5 minutes?
     
  2. IC3D

    IC3D Registered

    Joined:
    Feb 16, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    So I found some Info regarding chkservd script configuration; which is really dated:
    http://forums.cpanel.net/f5/cron-jobs-restart-services-22085.html

    so - find * | grep chkservd

    lead me here: /etc/chkserv.d/chkserv.d.conf

    which listed all the services:
    cpsrvd:1
    exim:1
    ...
    ...
    ...
    pop:1

    .... I changed pop from 1 to 0 ... (disable)

    waiting another go around (5 min) to see if this finally stops


    Assuming this is right this time, we shall see
     
    #2 IC3D, Mar 1, 2011
    Last edited: Mar 1, 2011
  3. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    cppop is deprecated in recent versions of cPanel and should be disabled anyway. Editing the /etc/chkserv.d/chkdservd.conf file is the correct approach. Also, remove the cppop file from /etc/chkserv.d. Restart tailwatchd (chkservd is a driver that is part of tailwatchd) and watch /var/log/chkservd.log to make sure the service is no longer being detected as down:

    Code:
    # mv /etc/chkserv.d/cppop /root
    # /scripts/restartsrv_tailwatchd
    # tail -f /var/log/chkservd.log
    Use Ctrl+C to stop the tail -f command.
     
  4. IC3D

    IC3D Registered

    Joined:
    Feb 16, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Much appreciation on the fast response and the detail...

    I will have to go back through and cleanly do this per your notes.... for now chkserv process isn't checking, restarting or throwing errors on cppop anymore!

    Thanks
     
  5. stainer1

    stainer1 Registered

    Joined:
    May 29, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Would massively appreciate help with the same problem. Disabled email due to using GoogleApps for email, but am getting the POP automagical email every 5 mins - argh!

    Bit of a server noob I'm afraid.

    Tried SSH:

    Code:
    # mv /etc/chkserv.d/cppop /root
    # /scripts/restartsrv_tailwatchd
    # tail -f /var/log/chkservd.log
    But the first line gives this message:

    Thanks!
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    What scripts do you have in /etc/chkserv.d location? If you have one called pop instead, move that one:

    Code:
    mv /etc/chkserv.d/pop /root
     
Loading...

Share This Page