Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Disabling email completely for an account/domain?

Discussion in 'E-mail Discussion' started by movielad, Nov 3, 2004.

  1. movielad

    movielad Well-Known Member

    Joined:
    May 14, 2003
    Messages:
    109
    Likes Received:
    2
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Twitter:
    Is there a way of completely disabling email for an account to the extent that the domain is not picked up in Exim as a local domain? Short of setting up forwarding, I can't see an easy way of doing this without much fiddling.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. WebHostPro

    WebHostPro Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,651
    Likes Received:
    15
    Trophy Points:
    318
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Twitter:
    I have seen this several times but no real answer has come from it.

    You can change the mx zone to point into to nowhere but it's really not a solution. Especially since users can change it back if they know what's going on.

    I would recommend suggesting it to cpanel for a new option. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Well, what you can do is to move the domain from /etc/localdomains to /etc/remotedomains. This will prevent exim from treating the email as local mail. You can redirect the MX record, the only problem with this is that the SMTP protocol does allow for fallback to the A record for the domain if the MX record doesn't work. If moving them from local to remote domains doesn't work, then a simple custom Exim ACL would.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice