Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Disabling Exim don't work?

Discussion in 'General Discussion' started by OooLong, Apr 12, 2017.

  1. OooLong

    OooLong Well-Known Member

    Joined:
    Mar 16, 2011
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    66
    cPanel Access Level:
    Website Owner
    So I disable exim in Service Manager Exim Mail Server

    Testing exim with /etc/init.d/exim status

    exim (pid 63048) is running...

    I thought it was supposed to be off? Does anyone know how to turn exim off permanently? Thanks.
     
  2. Eminds

    Eminds Well-Known Member

    Joined:
    Nov 10, 2016
    Messages:
    267
    Likes Received:
    20
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Login to your server with root and use the below command to stop the exim

    /etc/init.d/exim stop or service exim stop and to make sure no exim process running use command

    killall exim
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    604
    Likes Received:
    42
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Go to "Service Manager" in WHM, uncheck exim. Save your changes. Log onto SSH and stop exim using below command

    service exim stop

    Once you have disabled in Service Manager, chkservd won't restart it
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,961
    Likes Received:
    1,821
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm unable to reproduce the issue you have described on a test system. I disabled Exim via "WHM >> Service Manager" and confirmed it was no longer running:

    Code:
    # /scripts/restartsrv_exim --status
    (XID afy6hq) The “exim” service is disabled.
    # ps aux|grep exim
    root     24568  0.0  0.1 112656  2256 pts/0    S+   09:44   0:00 grep --color=auto exim
    You can kill the Exim process with the "kill -9 PID" command if the process is hanging.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice