Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Disabling Linux Caps (Bind)

Discussion in 'Bind/DNS/Nameserver' started by mehmetali, Feb 26, 2007.

  1. mehmetali

    mehmetali Member

    Joined:
    Feb 24, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    151
    How can i disable-linux-caps in Fedora Core5 ? (VPS)

    We make this style in Debain, but i wanna make it on Fedora Core 5

    Bind9 on Debian GNU/Linux Woody (3.0), Sarge (3.1), Etch (4.0)

    named provided by the bind9 binary packages fails to start because it is compiled with CAPs option.

    The debian way is to build** your own package without CAPs:

    su -
    cd /usr/src
    apt-get build-dep bind9
    apt-get source bind9
    cd bind9-x.x.x
    vi debian/rules

    Insert the following line after "./configure --prefix=/usr \":

    --disable-linux-caps \

    On a NPTL-enabled system you alse have to replace


    --enable-threads \

    with


    --disable-threads \

    or bind might refuse to run with an other user than root.

    Save the file and go ahead with compiling/installing:


    dpkg-buildpackage
    dpkg -i ../bind9-x.x.x.deb
    echo "bind9 hold" | dpkg --set-selections
     
    #1 mehmetali, Feb 26, 2007
    Last edited: Feb 26, 2007
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice