The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

disabling mod_ssl make httpd not work

Discussion in 'General Discussion' started by rprix, Aug 21, 2005.

  1. rprix

    rprix Member

    Joined:
    Oct 27, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    If i disable mod_ssl in /script/easyapache options, httpd isn't restarting.
    This is happening in one server but not in others, any idea why?

    Code:
    Syntax error on line 2 of /usr/local/apache/conf/httpd.conf:
    Invalid command 'Alias', perhaps mis-spelled or defined by a module not included in the server configuration
    /etc/rc.d/init.d/httpd start: httpd could not be started
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The obvious question, as per the error, is what does line 2 say in httpd.conf?
     
  3. rprix

    rprix Member

    Joined:
    Oct 27, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    It says nothing erroneous:

    Alias /bandwidth/ /usr/local/bandmin/htdocs/

    if is ignored (#) then error is next line, and next and next...
    If mod_ssl is active, then config file is ok from 1st line to last.
     
  4. 50c

    50c Active Member

    Joined:
    Jun 26, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    Yep.. the same occured to me... if you disable SSL support, you will get that error after you build apache..
     
Loading...

Share This Page