Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Disabling NetworkManager

Discussion in 'General Discussion' started by aptechnologies, May 31, 2018.

  1. aptechnologies

    aptechnologies Registered

    Joined:
    May 31, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Austin
    cPanel Access Level:
    Root Administrator
    Good evening,

    I am attempting to install cPanel and the installer asked me to disable NetworkManager. I have went ahead and did the instructions that was listed here. The cPanel installation goes through and installs. I went ahead and logged into the WHM interface to setup and was finished and was told to reboot to finish updating kernels. I went ahead and rebooted through WHM and the server rebooted successfully (via KVM) but was unable to connect to the internet. I am unable to ping the server from my side. I can access the server fine through KVM but not through WHM and/or SSH.

    I saw the warning on the How to Disable Network Manager article were it explicitly says:
    • Exercise extreme caution when you disable the Network Manager. Your server may lose its network services if you do not disable Network Manager correctly.
    What did I do wrong? I am running CentOS 7 latest version minimal install. I have tried looking through Google and couldn't find anything besides the cPanel article on How to Disable Network Manager.

    Thanks,
    apt
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,137
    Likes Received:
    222
    Trophy Points:
    173
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @aptechnologies

    It's hard to know what specifically went wrong here. If you're able to access the server through KVM can you show me the changes you made to ifcfg-eth0 and ifcfg-lo?

    Can you also ensure you restarted the network services?

    Code:
    systemctl enable network.service
    systemctl start network.service
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice