Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

disallow using nobody@yourhostname.com ?

Discussion in 'E-mail Discussion' started by Dreamy, Nov 17, 2008.

  1. Dreamy

    Dreamy Well-Known Member

    Joined:
    Sep 16, 2008
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    56
    I've noticed some php scripts use nobody@yourhostname.com to send out emails. How could I disable that kind of thing to happen in my server?
     
  2. lngtanseco

    lngtanseco Well-Known Member

    Joined:
    Jun 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    156
    WHM >> Server Configuration >> Tweak Settings

    Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)

    Check the above option to disable "nobody" from sending emails.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Dreamy

    Dreamy Well-Known Member

    Joined:
    Sep 16, 2008
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    56
    thanks man :)
     
  4. lngtanseco

    lngtanseco Well-Known Member

    Joined:
    Jun 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    156
    You're welcome!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Dreamy

    Dreamy Well-Known Member

    Joined:
    Sep 16, 2008
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    56
    now I've got problem that cpanel is unable to send out cron logs and other such messages. :confused:

    Before it used nobody.
     
  6. lngtanseco

    lngtanseco Well-Known Member

    Joined:
    Jun 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    156
    Possible options:

    1. You may want to send those logs to your local address then create a email forwarder to your remote email address.

    2. Re-enable nobody to send to remote email address, then fight off nobody spammer with different approach. (Example: http://www.webhostgear.com/232.html)

    Hope this helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice