The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

disallowing Sharing Nameserver Ips on whm not working

Discussion in 'Bind / DNS / Nameserver Issues' started by zurca, Nov 3, 2004.

  1. zurca

    zurca Member

    Joined:
    Oct 30, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hi I checked the allow Sharing Nameserver Ips on tweak settings on whm,
    For some reason after allowing this feature any mail sent from this server from users doesnt show the senders domain name in the reply address.

    ie:
    mail sent by user joedoe@joedomain.com

    when email is received it shows its coming from joedoe@servername.com,
    It doesnt shows joedomain at all, it shows the actual phisical servers name where its being sent.


    I figure this happended since i checked the allow Sharing Nameserver Ips on tweak settings on whm.

    So I tryed to disable this feature "uncheck" allow Sharing Nameserver Ips and save,
    then i refresh the tweak settings and the box is still checked.
    So in other words after I checked this feature , I cant get it to desable.

    Anyone has had this same issue,

    I am going creazy here.

    Please any suggestions will be apreciated.

    Thanks in advanced.
    :mad:
     
  2. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Interesting
    Even i can't have that undone.
    Perhaps a word from cpanel on this could enlighten us all.

    Anup
     
  3. zurca

    zurca Member

    Joined:
    Oct 30, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Anup,

    Is it doing the same thing with you?
    sending emails under the main servers name? instead of the actual domain name originated.
     
  4. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Not in general.
    I had a reseller complaining that *One Of His Domains* was having this problem after he changed from :blackhole: to :fal: for his default mail account.

    He deleted the domain and reet it up which resolved the issue but i still do not consider this as a viable solution.

    Anup
     
  5. zurca

    zurca Member

    Joined:
    Oct 30, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Well, Now that you mention this, when i changed the shared name server ips , i also did changed from :blackhole: to :localuser: for defaul catchall mail account. in settings tweak.

    I wonder if this was the reason,
    I will delete this domain and reinstall it again to see if it works,
    I will keep you posted.

    thanks
     
  6. zurca

    zurca Member

    Joined:
    Oct 30, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ahh, got it.

    Well I fixed the email header issue (user@server.domain.com)

    by going to whm Main >> Service Configuration >> Exim Configuration Editor

    and uncheck : Always set the Sender: header when the sender is changed from the actual sender. (Unchecking this will stop "On behalf of" data in Microsoft(R) Outlook, but may limit your ability to track abuse of the mail system.)

    now whoever sends email from this server the email header reply will be user@userdomain.com

    the way its suppost to be.


    But I still can not get the share name server ips unchecked fixed.
     
Loading...

Share This Page