The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disk IO Issues

Discussion in 'General Discussion' started by Nick-H, Mar 14, 2015.

  1. Nick-H

    Nick-H Registered

    Joined:
    Mar 14, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hi

    I setup a WHM server last week and I am noticing real high Disk Usage at certain times.

    I keep getting high loads at random times and when the server does a backup the server pretty much becomes unusable for an hour as pages won't load.

    There is not that much running on my server, the only CPU that is being used is for IO Wait really and the RAM isn't breaking above 15% usage it is just the disks.

    It is on a Xenserver VM (it is the only server on the host) that is using local disks within a RAID for storage.

    The main site on the server is a vBulletin forum, I have tried adjusting my.cnf to see if it was something like that but couldn't see anything.

    I spoke to cPanel support who thought it may be some sort of attack on the server, which was feasible but now the high load is on the server without many connections open.

    This was attached in the last high load alert:

    [QUOTE
    Total accesses: 531182 - Total Traffic: 872.7 MB
    CPU Usage: u68.31 s10.11 cu.03 cs0 - .137% CPU load
    9.27 requests/sec - 15.6 kB/second - 1722 B/request
    33 requests currently being processed, 0 idle workers
    [/QUOTE]

    When I run top or IOtop I see a lot of this:

    /usr/local/apache/bin/httpd -k start -DSSL

    Could it be Apache needs to be optimised as well as mySQL? Where would I start?
     
  2. Nick-H

    Nick-H Registered

    Joined:
    Mar 14, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    It is now under heavy load.

    When I run IOTOP it says:

     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page