The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disk usage full

Discussion in 'Security' started by Kausik, Jan 13, 2016.

  1. Kausik

    Kausik Member

    Joined:
    Aug 1, 2015
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Hi, my disk usage quota is full due to a virus/hack rather than my own files. This is because in a few days my 500GB quota has been maximized. I've SSH-ed into my root folder and tried to locate the extra files. I'm being told /dev/hda1 has 100% usage and is full. But when I try to navigate into it, I'm told it isn't a folder.

    Has anyone had similar experiences like this? I don't have much background in this. Thanks in advance!
     
  2. quizknows

    quizknows Well-Known Member

    Joined:
    Oct 20, 2009
    Messages:
    942
    Likes Received:
    57
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    devices like /dev/sda or /dev/hda in dev are "block devices." They represent physical disks, so they are not normal files or folders. /dev/hda1 represents the first partition on the physical disk.

    use a command such as "df -h" to see what folder or mount point places files on that. For example if I want to check space on /dev/sda1 I run "df -h" from a shell and I see this:

    Code:
    Filesystem  Size  Used Avail Use% Mounted on
    /dev/sda1  440G  8.3G  410G  2%  /
    /dev/sdc1  915G  96G  774G  11%  /home
    
    So to free up space on that disk I would need to remove files under / (the root directory) that aren't assigned to other partitions. For example to free space on /dev/sdc1 I would have to remove files under /home.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page