Disk Used is 0 for all accounts!!!

security

Member
Aug 18, 2006
17
0
151
hello ther

when i try to list account in WHM it give me the Disk Used = 0 for all accounts in the system

i have run /scripts/fixquotas several time and nothing change...

but i have notice that the script not scanning all the file system
it scan /usr /var/ / as i can see from the output


--------
Installing Default Quota Databases...../aquota.user..../quota.user..../boot/aquota.user..../boot/quota.user..../home/aquota.user..../home/quota.user..../tmp/aquota.user..../tmp/quota.user..../usr/aquota.user..../usr/quota.user..../var/aquota.user..../var/quota.user..../disk1/aquota.user..../disk1/quota.user..../home2/aquota.user..../home2/quota.user..../home/aquota.user..../home/quota.user..../home/aquota.user..../home/quota.user..../home/aquota.user..../home/quota.user..../home/aquota.user..../home/quota.user.....Done
Quotas are now on
touch: cannot touch `/disk1/quota.user': No such file or directory
touch: cannot touch `/disk1/aquota.user': No such file or directory
touch: cannot touch `/home2/quota.user': No such file or directory
touch: cannot touch `/home2/aquota.user': No such file or directory
Updating Quota Files......
quotacheck: Scanning /dev/sda5 [/] quotacheck: Old group file not found. Usage will not be substracted.
done
quotacheck: Checked 1779 directories and 20277 files
quotacheck: Scanning /dev/sda3 [/usr] quotacheck: Old group file not found. Usage will not be substracted.
done
quotacheck: Checked 20492 directories and 97945 files
quotacheck: Scanning /dev/sda2 [/var] quotacheck: Old group file not found. Usage will not be substracted.
done
quotacheck: Checked 595 directories and 25415 files


quotacheck: Scanning /dev/sda5 [/] quotacheck: Old group file not found. Usage will not be substracted.
done
quotacheck: Checked 1779 directories and 20277 files
quotacheck: Scanning /dev/sda3 [/usr] quotacheck: Old group file not found. Usage will not be substracted.
done
quotacheck: Checked 20492 directories and 97945 files
quotacheck: Scanning /dev/sda2 [/var] quotacheck: Old group file not found. Usage will not be substracted.
done
quotacheck: Checked 595 directories and 25418 files
---------
and when i move any file to these dir(s) such as /var and chown it for any user it display the disk used = file size

[email protected] [/var]# df -H
Filesystem Size Used Avail Use% Mounted on
/dev/sda5 11G 538M 9.5G 6% /
/dev/sda1 104M 18M 81M 18% /boot
none 2.2G 0 2.2G 0% /dev/shm
/dev/sda8 1.1G 76M 932M 8% /tmp
/dev/sda3 11G 2.6G 7.5G 26% /usr
/dev/sda2 11G 462M 9.6G 5% /var
/tmp 1.1G 76M 932M 8% /var/tmp
/dev/sdb1 248G 29G 206G 13% /home
/dev/sda7 38G 7.4G 29G 21% /var/lib/mysql

any idea ??!!
 
Last edited:

katmai

Well-Known Member
Mar 13, 2006
564
3
168
Brno, Czech Republic
/scripts/initquotas
/scripts/fixquotas
/scripts/fixeverything

check /etc/fstab and see if the lines from each HDD show that you have userquota enabled.
 

security

Member
Aug 18, 2006
17
0
151
wich os (linux or Freebsd) are you using?
Are the quota on in the kernel?
try quotaon -a in ssh shell.
[email protected] [~]# quotaon -a
quotaon: using //aquota.user on /dev/sda5 [/]: Device or resource busy
quotaon: using /usr/aquota.user on /dev/sda3 [/usr]: Device or resource busy
quotaon: using /var/aquota.user on /dev/sda2 [/var]: Device or resource busy
 

security

Member
Aug 18, 2006
17
0
151
/scripts/initquotas
/scripts/fixquotas
/scripts/fixeverything

check /etc/fstab and see if the lines from each HDD show that you have userquota enabled.
[email protected] [~]# cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults,usrquota 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/home /home ext3 defaults,usrquota 1 2
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
LABEL=/tmp /tmp ext3 defaults 1 2
LABEL=/usr /usr ext3 defaults,usrquota 1 2
LABEL=/var /var ext3 defaults,usrquota 1 2
LABEL=SWAP-sda6 swap swap pri=0,defaults 0 0
/dev/sdb1 /disk1 ext3 defaults,usrquota 0 0
/dev/hda /media/cdrom auto pamconsole,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
/dev/sdb1 /home2 ext3 defaults,usrquota 1 2
/dev/sdb1 /home ext3 defaults,usrquota 1 2
/dev/sdb1 /home ext3 defaults,usrquota 1 2
/dev/sdb1 /home ext3 defaults,usrquota 1 2
/dev/sdb1 /home ext3 defaults,usrquota 1 2
[email protected] [~]#