Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Displaying directories with no index page

Discussion in 'General Discussion' started by SylviaCaras, Nov 5, 2016.

Tags:
  1. SylviaCaras

    SylviaCaras Registered

    Joined:
    Nov 5, 2016
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Santa Cruz CA
    cPanel Access Level:
    Website Owner
    I own example.org and used to host it at Lunar Pages, which I managed myself. Now (cost savings; shared account) BlueHost has the materials and I can only access email.

    The material is 15 years old and I created it partly with Front Page and mostly manually with a text editor and ftp. There are three directories without index pages that when accessed used to display an alpha list of the contents and now show a 404. The contents are there, visible when I ftp. There never were index pages for three of the directories - this site is now mostly archival and I don't have development software - and there's no need for them. BlueHost must have made some changes; I can't deal with them directly because this is no longer my account; is there something they can tweak to display directories without an index page?

    For example: - Removed -

    (I am competent at the DOS 3.0 level and not with the more recent/sophisticated tools.)
     
    #1 SylviaCaras, Nov 5, 2016
    Last edited by a moderator: Nov 5, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You can add the following line to the .htaccess file within the document root to enable directory indexing:

    Code:
    Options +Indexes
    However, note that your hosting provider may have disabled the ability for accounts to override the default behavior.

    Thank you.
     
  3. SylviaCaras

    SylviaCaras Registered

    Joined:
    Nov 5, 2016
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Santa Cruz CA
    cPanel Access Level:
    Website Owner
    Working now; thank you!
     
    cPanelMichael likes this.
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
Loading...

Share This Page