Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

dissallow usage of all cgi-sys scripts

Discussion in 'General Discussion' started by eter4, Mar 11, 2004.

  1. eter4

    eter4 Well-Known Member

    Joined:
    Feb 16, 2002
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    306
    I have a customer that is being attacked. What the people are doing is trying to spam using the cgi-sys formmail in his hosting server.

    Is there a way to remove these scripts from the users directory or the server alltogether??

    Thanks

    JD
     
  2. DJ_Max

    DJ_Max Member

    Joined:
    Nov 18, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Chicago, IL- USA
    You can remove this from the Reseller WHM control panel.
    Packages >>Feature Manager


    Then on the packages creation/edit page there's an checkbox for "Email Scripts (cgiemail,formmail)"
    uncheck that.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. eter4

    eter4 Well-Known Member

    Joined:
    Feb 16, 2002
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    306
    Will this just remove the link from CPANEl or actually remove the scripts from the server?
     
  4. DJ_Max

    DJ_Max Member

    Joined:
    Nov 18, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Chicago, IL- USA
    I'm not for sure.:mad:
    I'll try it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Jabberwocky

    Jabberwocky Registered

    Joined:
    Feb 14, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    I've just actually done this... and it's pretty simple.

    Find your apache config (usually /etc/httpd/conf/httpd.conf

    and open it up in an editor on your shell (I reccomend pico/nano)

    Find the line that says

    and change it to

    Now use WHM to restart Apache and voila! no more
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice