The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DKIM not pass if am using custom domain

Discussion in 'E-mail Discussions' started by shufilkhan01, Mar 9, 2017.

Tags:
  1. shufilkhan01

    shufilkhan01 Registered

    Joined:
    Dec 9, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    india
    cPanel Access Level:
    Root Administrator
    We are sending mail with php script that is using with SMTP authentication , and one difference is there from address field we have given to custom domain , please check below details
    Host name : mail.domain.com(mail server)
    post : 587
    tls enabled
    user name :
    password

    to address : any
    from address : custom domain name like support@abc.com

    If we are use the same email ID in from address filed in script which is using with host name (mail server) , at that time DKIM will pass, but we need to add custom mail ID in From Address field .
    I have copy mail server TXT DKIM key record and created extra one TXT record in abc.com ,
    but still DKIM not passed .

    below url I have used for reference for setup extra TXT record
    Set Up Custom Domain Authentication: DKIM and SPF | MailChimp.com: KB Article

    Any one please help me .


    Regards,
    Shufil
     
  2. shufilkhan01

    shufilkhan01 Registered

    Joined:
    Dec 9, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    india
    cPanel Access Level:
    Root Administrator
    Could you please reply for this issue
    dkim not pass if i'm using different from address
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Check to see if the following option is enabled under the "Mail" tab in "WHM >> Exim Configuration Manager >> Basic Editor"

    EXPERIMENTAL: Rewrite From: header to match actual sender

    If so, try disabling this option to see if the issue persists.

    Thank you.
     
Loading...

Share This Page