The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DKIM thread length of 768 can't update

Discussion in 'Bind / DNS / Nameserver Issues' started by BottyZ, Aug 4, 2015.

  1. BottyZ

    BottyZ Member

    Joined:
    Jul 31, 2015
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Nottingham UK
    cPanel Access Level:
    Root Administrator
    Hi all,

    I recently acquired a new VPS and migrated an old cpanel shard hosting account accross to the new server. I've enabled DKIM and the key length is 768. I'm using BIND and was told over at the feautres request forum that the default now is 2048.
    I've tried all sorts to figure out how to increase the key length or generate a new key to use all without success. The raw DKIM key offered up in the cpanel under email authentication is always the old key value.

    I've tried disabling the DKIM and renabling.
    I've tried creating a new key using ssh openssl following these instructions https://en.wikibooks.org/wiki/Cryptography/Generate_a_keypair_using_OpenSSL and pasting the new public and private keys over those stored in /var/cpanel/domain_keys
    I've tried deleting the keys and restarting exim / dns server

    I've asked around and spent a few hours googling this and having no luck. I think it might have something to do with the migrated account but I don't know enough to find a workaround?

    Could anyone give me a push in the right direction please?
     
  2. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can ensure there are no TXT records related to DKIM populated in the domain name's DNS zone, and then try uninstalling and installing DKIM for the account. EX:

    Code:
    /usr/local/cpanel/bin/dkim_keys_uninstall $user
    /usr/local/cpanel/bin/dkim_keys_install $user
    Thank you.
     
Loading...

Share This Page