DNS Add or Edit Syntax Error

Operating System & Version
Centos 7 64 Bit
cPanel & WHM Version
v90.0.16

Dogus

Member
Nov 14, 2020
8
2
1
Turkey
cPanel Access Level
Root Administrator
Hi,

When I add something new from Dns Zone Manager, syntax error occurs. When I look at the domain.db file in / var / named, the last line comes with mixed and absurd characters. (For example: ^@^@^@ or p86)

I took the named.conf backup and tried / usr / local / cpanel / scripts / rebuilddnsconfig. And I tried using BIND instead of Powerdns.

How can I solve this problem?

cPanel/WHM Error: Failed to serialize zone file: There was an error while loading the zone for dogus.com. Please correct any errors in this zone manually and try again. The exact error from the parser was: syntax error, line 32: []

Thank you.
 

Attachments

Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
Hey there! Is line 32 also the line with the ^@ characters? If this were my zone I would manually edit it on the command line to ensure there were no extra lines or extra characters, increment the serial number, and save the zone manually. Then you can use the following command to test the zone for errors:

Code:
named-checkzone domain.com /var/named/domain.com.db
Once that is done I would expect things to work properly and no extra code to be added. If there is still extra code being added I would check the WHM >> Edit Zone Templates page to see if any customizations have been applied there that should not exist.
 

Dogus

Member
Nov 14, 2020
8
2
1
Turkey
cPanel Access Level
Root Administrator
Hey there! Is line 32 also the line with the ^@ characters? If this were my zone I would manually edit it on the command line to ensure there were no extra lines or extra characters, increment the serial number, and save the zone manually. Then you can use the following command to test the zone for errors:

Code:
named-checkzone domain.com /var/named/domain.com.db
Once that is done I would expect things to work properly and no extra code to be added. If there is still extra code being added I would check the WHM >> Edit Zone Templates page to see if any customizations have been applied there that should not exist.
Hello, when I try to add a record again after manually editing the wrong row, it automatically adds symbols with bull**** letters to the last line. When I look at the zone templates, everything is normal.
 

Attachments

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
Interesting - that might be a good thing for us to check directly if you could submit a ticket. If you do that, could you please post the ticket number here? That would let me post the solution for everyone once this is resolved.