The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DNS Changes only apply when i restart named

Discussion in 'Bind / DNS / Nameserver Issues' started by razR, Jul 18, 2012.

  1. razR

    razR Member

    Joined:
    Jul 18, 2012
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi There,

    This is my first time using cPanel/WHM and i like it very much, however when i add a (sub)domain to my server i need to restart NAMED manually before it actually applies.

    When i add a (sub)domain (example: google.nl) and i PING it on the webserver itself it says:

    ping google.nl
    ping: unknown host google.nl

    And when i do 'service named restart' it resolves perfectly.


    However also when i stop CSF & Iptables it updates it again but it doesnt help always.
     
    #1 razR, Jul 18, 2012
    Last edited: Jul 18, 2012
  2. razR

    razR Member

    Joined:
    Jul 18, 2012
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Nobody knows a solution? I'm getting tired to manually reload NAMED every time there is an DNS change occoured.
     
  3. razR

    razR Member

    Joined:
    Jul 18, 2012
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    UPDATE
    When i do the fixndc command i get the following

    Code:
     /usr/sbin/rndc status failed: WARNING: key file (/etc/rndc.key) exists, but using default configuration file (/etc/rndc.conf)rndc: connect failed: 127.0.0.1#953: connection refused
    \

    and

    Code:
    Error reloading bind on web: rndc: connect failed: 127.0.0.1#953: connection refused
     
    #3 razR, Jul 19, 2012
    Last edited: Jul 19, 2012
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The most important error message in this case is:

    There are several potential causes of this error. Feel free to submit a ticket so we can take a closer look:

    Submit A Ticket

    You can post the ticket number here, and we can update this thread with the exact cause of the problem after the issue is resolved.

    Thank you.
     
  5. radeonpower

    radeonpower Well-Known Member

    Joined:
    Jul 23, 2009
    Messages:
    129
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I had this problem few days ago.

    rndc failed to start until I disabled/stopped the 'portreserve' service. You might also need to delete the /etc/named.conf.cache file, new one will be generated automaticly.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    If you would like to determine if that's the cause of this issue, please post the output of the following command:

    Code:
    # grep portrelease /etc/init.d/named
    Depending on the version of CentOS you are using, you should see output such as:

    Code:
     [ -x /sbin/portrelease ] && /sbin/portrelease named &>/dev/null || :
    Thank you.
     
  7. radeonpower

    radeonpower Well-Known Member

    Joined:
    Jul 23, 2009
    Messages:
    129
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I'm using CentOS 6.3 and this command did not output anything.

    root@ns3 [~]# grep portrelease /etc/init.d/named
    root@ns3 [~]#

    The problem stopped anyway after I stopped portreserve. :P

    Funny enough though, I have few servers, some of them have this output and some dont.
     
    #7 radeonpower, Jul 19, 2012
    Last edited: Jul 19, 2012
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    If you are using CentOS 6.3, you can run the following commands to resolve this issue:

    Code:
    # mv /etc/init.d/named /etc/init.d/named.bak
    # yum reinstall bind
    You should then see the expected output when running:

    Code:
    # grep portrelease /etc/init.d/named
    Example output should be:

    Code:
    [ -x /sbin/portrelease ] && /sbin/portrelease named &>/dev/null || :
    If you see this output, you can then run:

    Code:
    # /etc/init.d/named stop; /etc/init.d/portreserve restart; /etc/init.d/named start; netstat -plan | grep 953 | grep named
    This should resolve the issue, and you should no longer receive connection refused errors when reloading rndc.

    Thank you.
     
  9. razR

    razR Member

    Joined:
    Jul 18, 2012
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Reinstalling BIND worked, thanks for the help :)
     
  10. ceylon

    ceylon Member

    Joined:
    Nov 15, 2009
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Got the same error on fresh installation of the CLOUDLINUX 6.3 x86_64 xenhvm
    Re-installed the system. But same error.

    Only resolve after re-installing bind.

    Thanks for the help and its really helpful.
     
Loading...

Share This Page