DNS edits always place domains in /etc/locadomain

hbidad

Well-Known Member
Apr 16, 2005
74
1
158
Irregardless if a client unchecks "Always accept mail locally even if the primary mx does not point to this server." The domain is removed from remotedomains to localdomains after any DNS edits.

This has been occurring with the last few Current builds.

The only temp work around is to enable the MX checking, but then we have many problems after "create new account" if the domain resolves elsewhere. Which is 99% of all created accounts.
 
Last edited:

mpierre

Well-Known Member
Jun 30, 2002
189
0
166
I have the same problem...
 

eperdeme

Well-Known Member
Oct 15, 2003
58
0
156
Manchester, UK
cPanel Access Level
DataCenter Provider
I have the same problem. It's a very annoying bug. Going to have to code a script to check localdomains for every MX record to ensure its resolving to a local IP otherwise move it to remotedomains - or something like that.
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
I have the same problem. It's a very annoying bug. Going to have to code a script to check localdomains for every MX record to ensure its resolving to a local IP otherwise move it to remotedomains - or something like that.
Feel welcome to let our technical analysts take a look at your server to see what may be causing this: http://tickets.cPanel.net/submit
 

eperdeme

Well-Known Member
Oct 15, 2003
58
0
156
Manchester, UK
cPanel Access Level
DataCenter Provider
Allowing access is very frustrating as means modifying several software and hardware firewalls and our last ticket went round in circles for ages trying to understand what we was saying/

The problems because cPanel does not check when a domain is parked on the server regardless of the Tweak Settings to setup local/remotedomains.

If you go to MX edit in the cPanel interface it says 'do not force local delivery' however it ignores this until you say 'force local' then remove 'force local' AND before all this you must specify a MX record.

cPanel should understand if BIND is disabled then not to refer to any local Zone file it creates and lookup the MX on park.