Aldo Barrios

Registered
May 24, 2018
1
0
1
Mexico
cPanel Access Level
Root Administrator
I found may errors in my domain, but we have configured the A records,
both dns are responding, why? because i have another domain
- Removed - and all is working.

I have the same configuration in example.mx and example.com

Here the errors

1Nameservers A records ERROR: Some of your DNS servers do not have A records at all. I could not find any A records for the following DNS servers:
ns1.example.mx
ns2.example.mx
You must have A records for all of your nameservers.
**************************************************************************
Mismatched NS records
WARNING: One or more of your nameservers did not return any of your NS records.
DNS servers responded ERROR: One or more of your nameservers did not respond:
The ones that did not respond are: ns2.example.mx ns1.example.mx
***************************************************************************
Multiple Nameservers ERROR: Looks like you have less than 2 nameservers. According to RFC2182 section 5 you must have at least 3 nameservers, and no more than 7. Having 2 nameservers is also ok by me.
****************************************************************************
Missing nameservers reported by your nameservers You should already know that your NS records at your nameservers are missing, so here it is again:
ns1.example.mx.
ns2.example.mx.
*****************************************************************************
SOA Error SOA record No valid SOA record came back!
MX Error MX Records Oh well, I did not detect any MX records so you probably don't have any and if you know you should have then they may be missing at your nameservers!
WWW Error WWW A Record ERROR: I could not get any A records for example.com
(I only do a cache request, if you recently added a WWW A record, it might not show up here.)




I have anothers domains with the same issue.. and others without issues.

The problem began when i detected that the emails from gmail are not being delivered to my domains.
i am receiving the following error:

DNS Error: 797636 DNS type 'mx' lookup of example.com responded with code SERVFAIL
 
Last edited by a moderator:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,257
313
Houston
Hello @Aldo Barrios

From this it looks like you have some DNS issues. If the DNS is hosted on the server you'll need to ensure that the zone files are correct. You can do this by going to WHM>>DNS Functions>>Edit DNS Zone

I'd ensure the following:
1. Both of your nameservers have valid A records
2. Both have valid NS records in the domains zone files
3. As far as the SOA I am assuming once you have valid nameservers added this error will be resolved.

If you're not sure how to do this you might want to contact your provider or system administrator for assistance. If you don't have one you might find one here: https://go.cpanel/net/sysadmin.

Thanks!