Stuff4me2win

Member
Jul 25, 2012
8
0
1
cPanel Access Level
Root Administrator
I'm working on a server for a client of mine. Although I have some experience with Unix (Sun), and can get around pretty good from a command line, I'm having issues helping them with setting up their new server.

My issues seems to mostly be mail related, as they are queued at the server and cannot talk back to the submitting server. So if I send a mail from hotmail.com to centbomber.de, I can see the message on the WHM email queue, but it can't validate the hotmail.com address. Given this, I've searched this forum for answers, but not much has helped me figure out if my DNS records are correct. I've put centbomber.de into the intodns.com but the data really doesn't help me understand what is needed to fix the issues.

Upon further research, I cannot ping, traceroute, or nslookup any addresses outside the server. Everything is locally resolved. I set up the server on Saturday and really just put in defaults in the WHM setup.

Once the DNS is set up, I'll be setting up multiple email addresses [email protected] in Cpanel, which I have no issues doing.

Any help with fixing these issues would be greatly appreciated.

Thanks in Advance.
A.J. Rosner,
 

JayFromEpic

Well-Known Member
Apr 2, 2011
218
8
68
Scottsdale
cPanel Access Level
Root Administrator
Twitter
From looking at the intodns report, I can see a couple things you may want to consider correcting to fix the issue.

On the report under your MX records, it states:

10 mail.centbomber.de 5.9.56.142

It should be showing as:
0 mail.centbomber.de 5.9.56.142

In order to fix that, you need to login to that accounts cPanel and click on the MX records section in cpanel. From there you need to make sure your Email routing is set to Local Mail Exchanger. From there at the bottom portion of the page, you will see the MX entry for this domain. You need to click on edit next to the entry listed and change the priority to 0.

Also if you are using a third party service to manage your DNS, make sure you have the proper records set there to pull the mail from the server. If you need help setting that up, let me know.
 

Stuff4me2win

Member
Jul 25, 2012
8
0
1
cPanel Access Level
Root Administrator
From looking at the intodns report, I can see a couple things you may want to consider correcting to fix the issue.

On the report under your MX records, it states:

10 mail.centbomber.de 5.9.56.142

It should be showing as:
0 mail.centbomber.de 5.9.56.142

In order to fix that, you need to login to that accounts cPanel and click on the MX records section in cpanel. From there you need to make sure your Email routing is set to Local Mail Exchanger. From there at the bottom portion of the page, you will see the MX entry for this domain. You need to click on edit next to the entry listed and change the priority to 0.

Also if you are using a third party service to manage your DNS, make sure you have the proper records set there to pull the mail from the server. If you need help setting that up, let me know.

Thanks for the info, but it doesn't solve my routing issues with other network tools such as nslookup and traceroute.

When I try to do lookups by IP I get the following:
[email protected] [/etc]# nslookup 5.9.56.142
;; connection timed out; trying next origin
;; connection timed out; no servers could be reached

[email protected] [/etc]# nslookup 193.47.99.3
;; connection timed out; trying next origin
;; connection timed out; no servers could be reached

I saw somewhere on this forum where port UDP 53 may be blocked by firewall causing a similar issue I'm having.
I don't know where those firewall settings are though.
 

JayFromEpic

Well-Known Member
Apr 2, 2011
218
8
68
Scottsdale
cPanel Access Level
Root Administrator
Twitter
That is odd. The steps I gave should have solved that issue. If you are concerned about the firewall, try executing this via command: iptables -L and see if ports 25, 26, 143, 993, 465, 53, 953.

If port 53 isnt working or if there is a rule in your iptables, let us know.
 

Stuff4me2win

Member
Jul 25, 2012
8
0
1
cPanel Access Level
Root Administrator
Seems to me that there shouldn't be any issues:

[email protected] [~]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
acctboth all -- anywhere anywhere

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
acctboth all -- anywhere anywhere

Chain acctboth (2 references)
target prot opt source destination
tcp -- webserver.centbomber.de anywhere tcp dpt:http
tcp -- anywhere webserver.centbomber.de tcp spt:http
tcp -- webserver.centbomber.de anywhere tcp dpt:smtp
tcp -- anywhere webserver.centbomber.de tcp spt:smtp
tcp -- webserver.centbomber.de anywhere tcp dpt:pop3
tcp -- anywhere webserver.centbomber.de tcp spt:pop3
icmp -- webserver.centbomber.de anywhere
icmp -- anywhere webserver.centbomber.de
tcp -- webserver.centbomber.de anywhere
tcp -- anywhere webserver.centbomber.de
udp -- webserver.centbomber.de anywhere
udp -- anywhere webserver.centbomber.de
all -- webserver.centbomber.de anywhere
all -- anywhere webserver.centbomber.de
all -- anywhere anywhere
[email protected] [~]#
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello :)

Users should be able to use your mail server for sending email. Port 25 is open and responding to connection attempts:

Code:
-sh-3.2$ telnet mail.centbomber.de 25
Trying 5.9.56.142...
Connected to mail.centbomber.de (5.9.56.142).
Escape character is '^]'.
220-webserver.centbomber.de ESMTP Exim 4.77 #2 Fri, 27 Jul 2012 20:48:12 +0200 
220-We do not authorize the use of this system to transport unsolicited, 
220 and/or bulk e-mail.
However, you have mentioned several times that you are unable to use your server to connect to remote servers. Have you checked to ensure you are using valid DNS resolvers in the /etc/resolv.conf file? If not, try changing the resolvers in this file to public resolvers that are known to work. EX:

Code:
nameserver 8.8.8.8
nameserver 4.2.2.2
As always, feel free to submit a support ticket so we can take a closer look:

Submit A Ticket

You can post the ticket number here so we can track the issue.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Adding those two addresses in my resolv.conf fixed the issue.
Is it ok to leave them in there?
Yes, it's acceptable to leave those public resolvers in the /etc/resolv.conf file. However, ideally, you should consult with your data center/hosting provider to see which resolvers they provide by default.

Thank you.