The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DNS Issue when adding a subdomain

Discussion in 'Bind / DNS / Nameserver Issues' started by Senor, Apr 8, 2008.

  1. Senor

    Senor Member

    Joined:
    Jun 12, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Greetings!

    Whenever someone adds a subdomain via cPanel, an A entry is added instead of a CNAME entry. I looked through the template files but was unsure what to change so future subdomains are added with a CNAME entry. Could someone tell me where to make the change?

    Thanks,
    Jay
     
  2. sarhosting

    sarhosting Well-Known Member

    Joined:
    Oct 1, 2007
    Messages:
    164
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    United States
    cPanel Access Level:
    Root Administrator
    Twitter:
    I would delete the primary domain and then re addit - sounds like the DNS Records are all fucked up.
     
  3. Senor

    Senor Member

    Joined:
    Jun 12, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I checked the results on another cpanel box of mine and it too added an A record when I created a new subdomain. Is this the correct way of doing this? It doesn't make sense to me to point a subdomain to an IP (A record), especially if there are multiple sites on the same box. Wouldn't setting it up as a CNAME entry work better?

    Thanks.
     
Loading...

Share This Page