The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DNS Mail Trouble

Discussion in 'Bind / DNS / Nameserver Issues' started by ddeans, May 10, 2004.

  1. ddeans

    ddeans Well-Known Member

    Joined:
    Feb 13, 2004
    Messages:
    296
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Maryland
    Hey!

    Having some small trouble here that I can't figure out. I am sure that I am missing something, just not quite sure what it is. If anyone can help it would be greatly appreciated.

    I found out that I cannot send mail to ceratain recipients, AOL etc. I am not listed on SPEWS or anyother spam site.

    Here is the Error:

    SMTP error from remote mailer after MAIL FROM:<globalup@server9.mysite.net> SIZE=1725:
    host mx1.optonline.net [167.206.5.6]: 550 5.1.8 invalid/host-not-in-DNS return address not allowed

    SMTP error from remote mailer after MAIL FROM:<dan@server9.mysite.net>:
    host mailin-01.mx.aol.com [64.12.138.57]: 550 REQUESTED ACTION NOT TAKEN:
    DNS FAILURE


    I have Reverse DNS added, but still get the same error. Can anyone tell me what it is?

    Thanks!
     
  2. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    Its not a reverse issue..

    $ host server9.mysite.net
    Host server9.mysite.net not found: 3(NXDOMAIN)

    Shows no such hostname...

    and from the auth NS...
    $ host server9.mysite.net NS71.WORLDNIC.COM
    Using domain server:
    Name: NS71.WORLDNIC.COM
    Address: 216.168.225.211#53
    Aliases:

    Host server9.mysite.net not found: 3(NXDOMAIN)

    You need to add entries into DNS for the hostname server9.mysite.net
     
  3. ddeans

    ddeans Well-Known Member

    Joined:
    Feb 13, 2004
    Messages:
    296
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Maryland
    I have added it in. It's been added in since i got the server.

    Is there something wrong with the way the DNS is setup?
     
  4. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    first, mysite.net is the REAL domain? If it is, your Authoritive DNS servers are NOT publishing the zone. Do you have any other domains on that server?
    Whats in /etc/named.conf? Is the zone listed there? is worldnic.com on the same server as you?
    worldnic seems to be the delegated dns servers, but they are not you, that one seems to be owned by verisign. If you are doing the dns for mysite.net then you need t change the delegaton to your server and your dns servers.
     
  5. ddeans

    ddeans Well-Known Member

    Joined:
    Feb 13, 2004
    Messages:
    296
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Maryland
    I just used mysite.net because i didn't want to publish my url on this site.

    If you wan't i'll pm you the site address
     
  6. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    Not posting the real URL makes it VERY difficult...
    pm me the domain if you like...
     
  7. ddeans

    ddeans Well-Known Member

    Joined:
    Feb 13, 2004
    Messages:
    296
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Maryland
    Any other ideas?
     
  8. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    The way I read this, you don't have FORWARD dns for server9.mysite.net
    That would prevent your email from going through as well...
     
  9. ddeans

    ddeans Well-Known Member

    Joined:
    Feb 13, 2004
    Messages:
    296
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Maryland
    What do you mean by FORWARD Dns?

    Thanks!
     
  10. ddeans

    ddeans Well-Known Member

    Joined:
    Feb 13, 2004
    Messages:
    296
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Maryland
    Okay, I found out that it works on some domains on my servers but not all of them... Could it be something serverside with the DNS entries? How can I check them?
     
  11. hostit1

    hostit1 Well-Known Member

    Joined:
    Jul 24, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    0
    I had a similiar problem on about 21 cpanel servers. For some reason the resolver was messed up /etc/resolv.conf

    I have no explination on how these entries dissapeared, but it did. People could not send mail anywhere except locally.

    I simply went into cpanel and clicked on (I believe the resolver configuration link) at the top and re-added our resolver ip addresses.

    This absolutely fixed the problem.

    Sincerely,

    Tim Rice
    Host It Now Networks
    http://hostitnow.com
     
Loading...

Share This Page