DNS not authoratative (Can't Add/Park Domains in cPanel)

PixelSide

Registered
Jan 8, 2010
1
0
51
I am paying a monthly fee for a managed master reseller account (I don't have root WHM access) for my domain, pixside.info.

I wanted to make my primary reseller account that I'll be selling my own hosting from to use the custom nameservers ns1.pixside.info and ns2.pixside.info. Therefore, I went to my registrar, GoDaddy and created the following custom domain servers.

ns1.pixside.info - 208.43.76.115 (this is a dedicated IP I purchased and my provider instructed me to use this one as my ns1 nameserver.)

ns2.pixside.info - 208.43.82.187

The next step I did was edit the dns zone for pixside.info to include the following:

<-- Click to view

After doing that, I went to my WHMMasterResellers page and plugged in the custom nameservers instead of the default ones.

<-- Click to view

However, Here is the problem I'm facing.

Cpanel accounts can be made with the default domain just fine, as WHM is forced to put the domain entered onto the account. But going into that specific cpanel and trying to addon or park the domain shows the following error.

There was a problem creating the addondomain.
Error from park wrapper: Using nameservers with the following IPs: 208.43.82.187,208.43.76.115 Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.
I talked with my hosting provider and they had this to say:

That's because the domain is not pointing to us. When ever you add a domain to an existing cPanel it needs to point to us first. You can add it by creating a new cPanel account in WHM so its not required to point to us..
However, I forced the domain to be parked on my cPanel account via WHM and viola, the domain worked perfectly. I also did a dns lookup on traintrue.info and it returned the correct nameservers and IPs. But they claim the domain is not pointing to them? This doesn't make any sense...

So what I don't understand is let's say for example the pixside.info account has the default domain pointed to ns1.pixside.info ans ns2.pixside.info.

I want to add the domain traintrue.info to this cPanel account. traintrue.info points to ns1.pixside.info and ns2.pixside.info and has fully propagated but when trying to add or park the domain from cpanel, I get the same error stated above.

I went back to GoDaddy and they told me this is because ns1.pixside.info and ns2.pixside.info are not configured to be authoritative on the server.

So who is to blame here and what needs to be done to fix it? Here is the entire DNS zone for pixside.info:



By the way, my host refuses to enable the following setting for security reasons:

Allow Creation of Parked/Addon Domains that resolve to other servers (i.e. domain transfers) [This can be a major security problem. If you must have it enabled, be sure to not allow users to park common internet domains.]

Any help would be greatly appreciated as I am very good with working in cPanel, but still a super novice at WHM.