The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DNS Only but Exim giving me grief.

Discussion in 'E-mail Discussions' started by Alcedema, Sep 28, 2009.

  1. Alcedema

    Alcedema Member

    Joined:
    Mar 14, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    We've installed DNS Only on one of our edge servers and wish to make it into a spam gateway.

    I've installed postfix and now I'm getting email after email about exim not running. Why is exim running by default on DNS only server? I can't even see an exim process running, let alone find out how to disable/remove it. There's nothing about mail in the WHM for DNS only.

    Thanks for any help!
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    You will need to disable it in the service manager in whm.

    DNSONLY requires a mail server to be able to send out alerts.
     
  3. Alcedema

    Alcedema Member

    Joined:
    Mar 14, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi, we're not seeing it listed in Service Manager. All we have listed is:

    ipaliases
    mysql
    named
    sshd
    syslogd
    tailwatchd => chkservd


    This is WHM DNS Only 11.24.2 - X 3.9
     
  4. Alcedema

    Alcedema Member

    Joined:
    Mar 14, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Can anyone point me to the config file or DB entry that will stop the cron from checking exim (even though it wasn't running in the first place but the script still seemed to notice when I installed postfix) as exim really isn't in the service list for me to uncheck.
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    You can manually disable it by running:

    Code:
    touch /etc/eximdisable
    /sbin/service exim stop
     
Loading...

Share This Page