The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DNS Only changing default SMTP port?

Discussion in 'E-mail Discussions' started by Steve Kemp, Feb 4, 2016.

  1. Steve Kemp

    Steve Kemp Registered

    Joined:
    Jul 29, 2014
    Messages:
    4
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Mount Clear, Victoria, Australia, Australia
    cPanel Access Level:
    DataCenter Provider
    We have a DNS only server at VPS.net within a Softlayer DC and they have apparrently blocked all port 25 traffic

    Im wondering what the correct way to change exim in a DNS only setup is to force it to send via port 26 rather than 25 as we find that the mail queue is sitting undelivered.

    We have 26 enabled in the firewall and in the service manager but it still isnt allowing mail to send out

    any ideas or guides i can review that show the correct procedure as i found it a bit confusing in exim.conf as to the correct way to do it

    TIA
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. Steve Kemp

    Steve Kemp Registered

    Joined:
    Jul 29, 2014
    Messages:
    4
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Mount Clear, Victoria, Australia, Australia
    cPanel Access Level:
    DataCenter Provider
    Thanks for the link...however this addresses incoming mail issues to port 25... ours is outgoing... ie we need mail thats queued on the server to be sent out via port 26...

    is this not possible to achieve?
     
  4. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    Not with them anymore - and even if you did change the port, it may still cause an issue with the recipient server trying to complete the transaction since SMTP by default communicates on port 25.

    Outbound Email on Port 25 | SoftLayer

    So a couple options for you:

    1) Do what they recommend, and implement Mandrill or Sendgrid. I'm not sure about Sendgrid, but Mandrill is free up to 12,000 sends per month. I have instructions for both:

    Implementing Mandrill with Exim on cPanel - The cPanel Admin
    Implementing SendGrid with Exim on cPanel - The cPanel Admin

    2) Hacky fix, but it might work:

    - Edit /etc/exim.conf.local (or create it if it doesn't exist)
    - Add the following (or edit the existing @config@ section if it already exists:

    @config@
    daemon_smtp_ports = 26 : 465


    - Run: /scripts/buildeximconf
    - Run: service exim restart

    I don't think #2 will fix your issue though.
     
Loading...

Share This Page