Hello to all again :)

Recently when installing DNSonly I found that stunnel was not starting. No errors are reported by the init scripts ($? always = 0 after a restart) however it looked to me like stunnel was just plain missing.

And low and behold it was , found this in /var/log/stunnel-4.04-build.log:

static-stunnel: line 22: cd: /usr/local/cpanel/src/3rdparty/gpl/stunnel-4.04: No such file or directory
static-stunnel: line 22: ./configure: No such file or directory
make: *** No rule to make target `clean'. Stop.
make: *** No targets specified and no makefile found. Stop.

So I went to /usr/local/cpanel/3rdparty/gpl and found stunnel had not yet ben un-tarred by the installer.

I uncompressed it, wen in and did a ./configure, make clean then make, make install but I don't think things are getting deposited where they need to be.

upcp did not fix the problem.

Does anyone know how the installer installs stunnel? I tried this on fc4 and centos, same issue.
nettigritty said:
did you try a forced rebuild ?

/scripts/upcp --force
Yes.. tried everything that I knew that may pick up on the fact that stunnel wasn't right and re-install / remake it.

I found the cause.

/usr/local/cpanel/install/stunnel-static was looking for the following :


The dnsonly universal installer deposits 4.15

That explains why it was not un-tarred . So I untarred 4.15, did a
make clean
make install

then in /usr/local/cpanel/src/3rdparty/gpl I did :

ln -s stunnel-4.15 stunnel-4.04

Then I re-ran /usr/local/cpanel/install/stunnel-static

and all is well again :) Should probably submit this one to bugzilla.