The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DNS problems

Discussion in 'Bind / DNS / Nameserver Issues' started by 1elko1, May 27, 2007.

  1. 1elko1

    1elko1 Member

    Joined:
    Mar 9, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
  2. bashcpanel

    bashcpanel Well-Known Member

    Joined:
    Apr 15, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    You can check /etc/named.conf and make sure entries are same as pasted below.

    ==================


    allow-recursion { localhost; };
    eg:
    options {
    directory "/var/named";
    pid-file "/var/run/named/named.pid";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    allow-recursion { localhost; };
    };

    =====================

    This will remove open dns error .

    Thanks,
     
  3. 1elko1

    1elko1 Member

    Joined:
    Mar 9, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Last login:
    root@echo [~]# /etc/named.conf
    -bash: /etc/named.conf: Permission denied
     
  4. 1elko1

    1elko1 Member

    Joined:
    Mar 9, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Am not very good with linux and the commands lol.

    So i do appriciate your help, but seems like i dont know where to check that?
     
  5. bashcpanel

    bashcpanel Well-Known Member

    Joined:
    Apr 15, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Well , i think you are not logged in as root in server.

    If you are not the root user of server , you need to contact your host provider , they will do it for you. Because this task needs root access.

    Thanks,
     
  6. 1elko1

    1elko1 Member

    Joined:
    Mar 9, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    When i use shh client i downloaded the file and opened it with note pad..
     
  7. 1elko1

    1elko1 Member

    Joined:
    Mar 9, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Can some one help me ?
     
  8. WhmSonic

    WhmSonic Well-Known Member

    Joined:
    Mar 19, 2007
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Login to your root ssh and use below command, open the /etc/named.conf if you cant use pico command or return error let me know.

    Code:
    pico /etc/named.conf
    Follow read below now

     
  9. 1elko1

    1elko1 Member

    Joined:
    Mar 9, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    pico /etc/named.conf
    GNU nano 1.2.4 File: /etc/named.conf

    include "/etc/rndc.key";

    controls {
    inet 127.0.0.1 allow { localhost; } keys { "rndckey"; };
    };

    //
    // named.conf for Red Hat caching-nameserver
    //

    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    /*


    all i get
     
  10. WhmSonic

    WhmSonic Well-Known Member

    Joined:
    Mar 19, 2007
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Im gonna give you the information about this but this is smart issue, remember to take backup /etc/named.conf file. Follow below link your own risk.

    Follow: http://www.webhostgear.com/321.html
     
    #10 WhmSonic, May 27, 2007
    Last edited: May 27, 2007
  11. 1elko1

    1elko1 Member

    Joined:
    Mar 9, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    how do i restart the service

    Save the changes and restart the named service: service named restart?
     
Loading...

Share This Page