Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

DNS Propagation on DNSOnly name servers

Discussion in 'Bind/DNS/Nameserver' started by TOCS, May 8, 2019.

Tags:
  1. TOCS

    TOCS Registered

    Joined:
    May 8, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brisbane Australia
    cPanel Access Level:
    Root Administrator
    I'm having an issue on our 2 name servers with WHM DNSOnly installed. There is a DNS cluster on our main WHM to ns1 ans ns2. As far as I can tell, this replication is working but each other the name servers are not propagating normally, and when you attempt to resolve the A record for ns1 or ns2 it does not come back with a answer.

    Code:
    ============================================
    [user@server ~]$ dig @103.74.xxx.xx a ns1.example.com
    
    ; <<>> DiG <<>> @103.74.xxx.xx a ns1.example.com
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 28483
    ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
    ;; WARNING: recursion requested but not available
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;ns1.example.com. IN A <<< NOTHING HERE >>>
    
    ;; Query time: 14 msec
    ;; WHEN: Wed May 08 14:33:57 AEST 2019
    ;; MSG SIZE rcvd: 44
    ============================================
    
    ============================================
    [user@server ~]$ dig @103.74.xxx.xx ns2.example.com
    
    ; <<>> <<>> @103.74.xxx.xx ns2.example.com
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 56825
    ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
    ;; WARNING: recursion requested but not available
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;ns2.example.com. IN A <<< NOTHING HERE >>>
    
    ;; Query time: 14 msec
    ;; WHEN: Wed May 08 15:35:26 AEST 2019
    ;; MSG SIZE rcvd: 44
    ============================================
    
    The world wide propagation shows it propagating half way around the world, - Removed - and - Removed -

    Our domain hosting and confirmed their are no issues, I am at a loss to explain why this is happening. Can anyone
     
    #1 TOCS, May 8, 2019
    Last edited by a moderator: May 8, 2019
  2. dalem

    dalem Well-Known Member PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,906
    Likes Received:
    127
    Trophy Points:
    368
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    perhaps you DNS resolvers are broken or just have not updated yet
    try with another resolver
    dig @8.8.8.8 ns1.example.com

    & double check that you have A records synced across all servers
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. TOCS

    TOCS Registered

    Joined:
    May 8, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brisbane Australia
    cPanel Access Level:
    Root Administrator
    Thanks, the DNS resolvers are set to the Google public IP's (8.8.8.8 and 8.8.4.4)

    We only have the one full WHM server which definitely has A records.


    dig @8.8.8.8 ns1.example.com

    ; <<>> DiG 9.9.4-RedHat-9.9.4-73.el7_6 <<>> @8.8.8.8 ns1.example.com
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 9819
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 512
    ;; QUESTION SECTION:
    ;ns1.example.com. IN A

    ;; Query time: 613 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Fri May 10 08:58:12 AEST 2019
    ;; MSG SIZE rcvd: 44
     
  4. dalem

    dalem Well-Known Member PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,906
    Likes Received:
    127
    Trophy Points:
    368
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    try syncing all record to all servers and use a different public resolver to check
    Googles usually update with 30 min or less

    double Check your cluster settings to make sure they are are syncing your ns1 & ns2 which I assume are your DNS only servers


    check a good domain to see if it resolves
    dig @8.8.8.8 google.com
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    TOCS and cPanelMichael like this.
  5. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,272
    Likes Received:
    2,153
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @TOCS,

    Can you confirm how you have configured the role of each DNSOnly server in WHM >> DNS Cluster on the hosting server?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. TOCS

    TOCS Registered

    Joined:
    May 8, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brisbane Australia
    cPanel Access Level:
    Root Administrator
    Our DNS cluster is set to use ns1 and ns2 (you are correct, they are our name servers) and Synchronize Changes. Both nodes have a green status tick on the WHM > DNS Cluser page and we are not receiving alerts of a failed cluster node.

    Also after checking IntoDNS, it seems that some of our domains (not all) are unable to resolve the name servers (mainly seems to be .com address)

    ns1.example.com [] (NO GLUE) [TTL=172800]
    ns2.example.com [] (NO GLUE) [TTL=172800]

    The following was run from our main hosting server.


    ; <<>> DiG 9.9.4-RedHat-9.9.4-73.el7_6 <<>> @8.8.8.8 google.com
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23531
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 512
    ;; QUESTION SECTION:
    ;google.com. IN A

    ;; ANSWER SECTION:
    google.com. 299 IN A 172.217.25.142

    ;; Query time: 108 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Mon May 13 08:34:15 AEST 2019
    ;; MSG SIZE rcvd: 55
     
  7. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,272
    Likes Received:
    2,153
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @TOCS,

    Can you open a support ticket so we can take a closer look and see why it's not working as expected? You can post the ticket number here and we'll link this thread to it.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice