DNS Propagation - only for verification

Jgoverenlc

Registered
Dec 5, 2022
2
0
1
Dayton
cPanel Access Level
Root Administrator
Hello, I am a new cPanel user and NOT a "web site person".
I am trying to add a TXT record in the DNS editor so I can verify using Azure Active Directory (I have confirmed the line is correct). I have done this before with KnowBe4 and I can see that line when I do a "dig" command.
I have let the record sit since Friday (it's now the next Monday) so that should be plenty of time, but it's still not showing up.

I don't know where to go from here, any suggestions?

thanks,
 

ServerHealers

Well-Known Member
Sep 21, 2015
95
53
68
India
cPanel Access Level
Root Administrator
I'd suggest making sure the domain name is using correct nameservers that this server owns. If the domain is using a 3rd party DNS like Cloudflare or similar, then you should make the changes at their side to take in effect.

for ns in $(dig DOMAIN ns +short); do echo "$ns - $(dig $ns +short)"; done
Run above command from your terminal, but make sure to replace DOMAIN with your actual domain name and see if the IPs resolved are the ones in the server.
 

Jgoverenlc

Registered
Dec 5, 2022
2
0
1
Dayton
cPanel Access Level
Root Administrator
Thanks for the reply!
it does look like they are using the name servers we expect: ns1.ourdomain.org and ns2.ourdomain.org

I called HostGator today and had my case escalated. they tried to tell i had to remove the google verification txt files!!
I did this, same kind of thing, a couple of months ago, for KnowBe4 and it worked perfectly.
After they told me it was a Microsoft issue, I finally got HostGator to admit that i had done everything correctly on my end and that it was a problem on their end.

Now i have to wait 24-48 hours for their DNS folks to respond.
ugh!

Thanks again,

Jim
 

cPanelWilliam

Administrator
Staff member
Mar 13, 2018
161
23
93
Houston
cPanel Access Level
Root Administrator
Hi!

If you can see the verification record with your "dig" command, but Microsoft cannot verify it, the server's firewall may be blocking Microsoft's IP addresses. If the verification record doesn't show up via "dig" or Microsoft's check, then there could be an issue with the DNS Zone or verification record. However, it would be difficult to verify this for sure without access to the server. If you do have root access, you can submit a ticket so our team can take a closer look.