ChristsFlock

Registered
Apr 15, 2013
3
0
1
cPanel Access Level
Root Administrator
Hello,

We had a problem with DNS not resolving to our new server for four days.

In the end, on a whim, I commented this line from /etc/named.conf

Code:
allow-query     { localhost; };
Only because it looked like that would only allow queries for localhost.

After I did that, everything started to resolve.

Is this the usual setting? I have never had this problem before, so it was very bizarre.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello :)

That is not a standard entry in the /etc/named.conf file. You can regenerate a default /etc/named.conf file in the future with a command such as:

Code:
# mv /etc/named.conf /etc/named.conf.backup
# /scripts/rebuilddnsconfig
Thank you.