The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DNS Server keeps Failing causing sites to be down

Discussion in 'Bind / DNS / Nameserver Issues' started by TheNetway, Jan 11, 2005.

  1. TheNetway

    TheNetway Member

    Joined:
    Oct 28, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    When I restart bind, I get this:

    named has failed, please contact the sysadmin (result was "named is not running"). Jan 11 06:21:52 iceberg named: named shutdown failed Jan 11 06:21:52 iceberg named: Removing chroot jail succeeded Jan 11 06:21:52 iceberg named: Removing chroot jail succeeded Jan 11 06:21:52 iceberg named: Setting up chroot jail succeeded Jan 11 06:21:52 iceberg named[31512]: starting BIND 9.2.3 -u named -c /etc/named.conf -t /var/lib/named/chroot Jan 11 06:21:52 iceberg named[31512]: using 1 CPU Jan 11 06:21:52 iceberg named[31512]: loading configuration from '/etc/named.conf' Jan 11 06:21:52 iceberg named[31512]: /etc/named.conf:2976: when using 'view' statements, all zones must be in views Jan 11 06:21:52 iceberg named: named startup succeeded Jan 11 06:21:52 iceberg named[31512]: loading configuration: failure Jan 11 06:21:52 iceberg named[31512]: exiting (due to fatal error)

    Does anyone have any other solution?
     
  2. Etheral

    Etheral Well-Known Member

    Joined:
    Dec 8, 2003
    Messages:
    208
    Likes Received:
    0
    Trophy Points:
    16
    hrmm, this is saying you havnt turned on your name server process, you can turn this on by:

    Main >> Service Configuration >> Enable Nameserver

    click ok, then try to restart your bind server :). feel free to contact me if you need more help.
     
  3. furquan

    furquan Well-Known Member

    Joined:
    Jul 27, 2002
    Messages:
    425
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    I just started facing this problem , tried all the usual fixscripts but nothing worked, then decided to check the bind version and to my dismay i found bind missing from my server except bindutils ...All gone :(. but all my entries are intact in /etc/named.conf so that is a relief

    i also did /scripts/upcp --force and all the usual /scripts but no luck


    Then i decided to reinstall bind from ssh using :-

    /scripts/installrpm bind

    This is the error that i get at the end :

    warning: /var/spool/cpupdates/bind-9.2.1-16.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
    error: Failed dependencies:
    kernel >= 2.3 is needed by bind-9.2.1-16
    Rebuilding local rpm provides list.....bind..Done

    although i have kernel ver "2.4.20-31.9smp"

    Opened an helpdesk ticket with Cpanel and they say i need to recompile my kernel with 2.3 ver.

    But this is strange, how did it just vanish in the thin air and now i need to compile kernel. Since i havn't done kernel recompile b4 its a nightmare for me.

    Can anobody on board assist. ?

    Regards.
     
  4. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    What is your ticket number?
     
  5. TheNetway

    TheNetway Member

    Joined:
    Oct 28, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    After doing what you said, it still fails....


    "named has failed, please contact the sysadmin (result was "named is not running"). Jan 11 15:17:00 iceberg named: named shutdown succeeded Jan 11 15:17:00 iceberg named: Removing chroot jail succeeded Jan 11 15:17:00 iceberg named: Removing chroot jail succeeded Jan 11 15:17:00 iceberg named: Setting up chroot jail succeeded Jan 11 15:17:00 iceberg named[6835]: starting BIND 9.2.3 -u named -c /etc/named.conf -t /var/lib/named/chroot Jan 11 15:17:00 iceberg named[6835]: using 1 CPU Jan 11 15:17:00 iceberg named: named startup succeeded Jan 11 15:17:00 iceberg named[6835]: loading configuration from '/etc/named.conf' Jan 11 15:17:00 iceberg named[6835]: /etc/named.conf:2976: when using 'view' statements, all zones must be in views Jan 11 15:17:00 iceberg named[6835]: loading configuration: failure Jan 11 15:17:00 iceberg named[6835]: exiting (due to fatal error) "


    Anything else?
     
  6. furquan

    furquan Well-Known Member

    Joined:
    Jul 27, 2002
    Messages:
    425
    Likes Received:
    0
    Trophy Points:
    16
    Hello Dan,

    My ticket number is 86104, Please assist

    Thank you
     
  7. furquan

    furquan Well-Known Member

    Joined:
    Jul 27, 2002
    Messages:
    425
    Likes Received:
    0
    Trophy Points:
    16
    Hello Everyone,

    The best part of all this bind isuse is that my sites are still running and its does not look like a Cached DNS issue.

    I am really worried what could be the reason ????

    One more thing I cannot see "Bind" listed under Server Status either, But it is selected under "Service Manager"


    Please Assist.
     
  8. furquan

    furquan Well-Known Member

    Joined:
    Jul 27, 2002
    Messages:
    425
    Likes Received:
    0
    Trophy Points:
    16
    Resolved

    This is just to inform every one that my issue has resolved and it had nothing to do with cpanel and its features :)

    Thank you Dan once again :D
     
  9. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Care to tell us what the solution was?
     
  10. furquan

    furquan Well-Known Member

    Joined:
    Jul 27, 2002
    Messages:
    425
    Likes Received:
    0
    Trophy Points:
    16
    Its just that we had an External DNS server ( i was'nt aware of )and since Bind was not running and not needed on the Cpanel server et all. It had no relavance to Cpanel.

    Enjoy :D
     
Loading...

Share This Page