Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

DNS Server Syntax Error

Discussion in 'Bind/DNS/Nameserver' started by flashweb, Sep 16, 2005.

  1. flashweb

    flashweb Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    253
    Likes Received:
    2
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Hi,

    In my new Cpanel server (FreeBSD 5.4) i get error on starting BIND.

    This is new server, no domains hosted, but named seems down.

    content of named are

    /scripts/fixrndc gives


    How do i correct this ?

    Regards,

    Annie Steephan
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. jesse

    jesse Member

    Joined:
    Jul 13, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    151
    Same problem here.
     
  3. jrehmer

    jrehmer Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Denver, CO
    Lines cannot begin with {

    Here is an example of how mine looks:

    Code:
    //
    // named.conf for Red Hat caching-nameserver
    //
     key "rndc-key" {
           algorithm hmac-md5;
           secret "25AtCNQJNCih14txC/77cQ==";
    };
    
    controls {
           inet 127.0.0.1 port 953
                   allow { 127.0.0.1; } keys { "rndc-key"; };
    };
    
    options {
            directory "/var/named";
            dump-file "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            /*
             * If there is a firewall between you and nameservers you want
             * to talk to, you might need to uncomment the query-source
             * directive below.  Previous versions of BIND always asked
             * questions using port 53, but BIND 8.1 uses an unprivileged
             * port by default.
             */
             query-source address * port 53;
    };
     
  4. jrehmer

    jrehmer Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Denver, CO
    Also, it appears you are trying to include the server key file, but then specifying it on the next line...which won't work, again refer to my example above.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice