Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

DNS - webmail.mydomain.co.uk not working...

Discussion in 'Bind/DNS/Nameserver' started by moosemoose, Oct 25, 2007.

  1. moosemoose

    moosemoose Member

    Joined:
    May 24, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    i've set up DNS records for http://webmail.mydomain.co.uk/ and told cPanel where it should go, but Apache or something isn't picking it up - it just goes to the (previous) first domain, www.somethingelse.co.uk, and displays the homepage.

    How can I see what's going wrong and where? it's really starting to annoy me, as there seems to be no reason why it's not functioning.

    Apache has this that cpanel's inserted:

    Code:
    <VirtualHost *.*.*.*:80>
        ServerAlias www.webmail.mydomain.co.uk
        [B]ServerAlias webmail.mydomain.co.uk[/B]
        ServerAdmin webmaster@mydomain.co.uk
        DocumentRoot /home/user/subdomains/webmail
        ServerName webmail.mydomain.co.uk
        <IfModule mod_suphp.c>
            suPHP_UserGroup user user
        </IfModule>
        <IfModule !mod_disable_suexec.c>
            User user
            Group user
        </IfModule>
        BytesLog /usr/local/apache/domlogs/webmail.mydomain.co.uk-bytes_log
        CustomLog /usr/local/apache/domlogs/webmail.mydomain.co.uk combined
        ScriptAlias /cgi-bin/ /home/user/subdomains/webmail/cgi-bin/
    </VirtualHost>
    
    the bold line was added myself, and mimics how it was on my previous server (which worked).
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice