DNS working but nslookup timeout

lukekenny

Member
Jan 24, 2018
18
3
3
Melbourne, Australia
cPanel Access Level
Root Administrator
Recently migrated from BIND to PowerDNS. Not sure if this is new behaviour, but the DNS seems to be working fine, all domains resolve, and external tools like mxtoolbox and ultratools are able to get domain records.

However, if I from Windows commmand like, run nslookup, then server ns1.mydomain.com, when I query a domain whose zone is on the server I get sometimes get DNS request timed out, and sometimes it works. Usually if I switch to the other name server in the cluster, ie go to ns2.mydomain.com, it works, but not always, failing with the same request timed out error.

What's going on here? Is there something that limits or prevents direct queries to the nameserver by nslookup?
 

quietFinn

Well-Known Member
Feb 4, 2006
1,707
353
438
Finland
cPanel Access Level
Root Administrator
Is it the same if you use the IP address of the nameserver?
 

quietFinn

Well-Known Member
Feb 4, 2006
1,707
353
438
Finland
cPanel Access Level
Root Administrator
what do you get if you run:
nslookup ns1.mydomain.com
 

lukekenny

Member
Jan 24, 2018
18
3
3
Melbourne, Australia
cPanel Access Level
Root Administrator
It must have been a glitch in the matrix. I've just tried to recreate the problem again, and everything came back fine. So actually everything is working normally. I've changed nothing but a few hours have passed.... maybe something along the way between me and the server was having an issue.