The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dns zone check NOT working when creating account by a reseller

Discussion in 'Bind / DNS / Nameserver Issues' started by ethical, May 16, 2014.

  1. ethical

    ethical Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    79
    Likes Received:
    2
    Trophy Points:
    8
    Ok so the option when creating a new account of. I tested it from the main WHM as well as from within a resellers WHM and used different packages as well...

    >> Use the nameservers specified at the Domain’s Registrar. (Ignore locally specified nameservers.)

    should be CHECKED off if you want to use the nameservers specified at the registrar, and ignore the local ones.

    so obviously shouldnt be used much.

    that said even if we leave this UNCHECKED when creating an account it STILL grabs the namservers from the registry!?

    running cpanel 11.42.1 build 15

    is this a bug?

    thanks
    John
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Have you verified the correct local name servers are configured in "WHM Home » Server Configuration » Basic cPanel & WHM Setup" and in "WHM Home » Resellers » Edit Reseller Nameservers and Privileges" for resellers?

    Thank you.
     
  3. ethical

    ethical Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    79
    Likes Received:
    2
    Trophy Points:
    8
    michael thanks for the reply, Yes. that was the first and second thing i checked, but really shouldnt have had to check since the nameservers it was grabbing could not have possibly been setup on the server.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket so we can take a closer look and reproduce the issue on your machine. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. ethical

    ethical Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    79
    Likes Received:
    2
    Trophy Points:
    8
    support ticket id 4963345
     
  6. cPanelKaden

    cPanelKaden Technical Analyst
    Staff Member

    Joined:
    Jun 10, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    This case has been resolved. There is an option within Tweak Settings that will cause this behavior:

    Always use authoritative (registered) nameservers when creating a new DNS zone. [?]
    When adding a new domain, if the domain is already registered, ignore the configured nameservers, and set the NS line to the authoritative (registered) ones.

    After turning this off, the server was able to create accounts using the locally specified nameservers.
     
  7. ethical

    ethical Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    79
    Likes Received:
    2
    Trophy Points:
    8
    ok thanks!
     
Loading...

Share This Page