The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DNS zones not transferring

Discussion in 'Bind / DNS / Nameserver Issues' started by sbrookeinmd, Aug 3, 2003.

  1. sbrookeinmd

    sbrookeinmd Member

    Joined:
    Aug 3, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I'm trying to use my cpanel server as a secondary nameserver. It's transferring a named.conf.dnstransfer ok. I can see all of my zones from the primary. Problem is that its then populating the named.conf with a bunch of this:

    type slave;
    masters {
    209.x.x.x;
    };
    type slave;
    masters {
    209.x.x.x;
    };

    (x's entered by me in place of octets)

    The zone names are not being populated but a place holder for every one of them is being created like the above. Something seems to be failing with the /scripts/makesecondary script. Anyone run into this?

    Also, I tried adding a zone as a slave manually and it worked. It successfully transferred the zone file for that domain. Problem is that the scripts overwrite the named.conf when I run something through WHM.

    cPanel.net Support Ticket Number:
     
  2. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Try checking if you don't have invisible characters in your named.conf file that's being transferred. I had no problems running this same script so far...
    You might also try for international characters in domain names, these might confuse perl 5.6.1 (5.8 is better at handling international stuff) some(and if I remember, perl is used by the cpanel scripts)

    cPanel.net Support Ticket Number:
     
  3. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
Loading...

Share This Page