The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dnsonly cpanel

Discussion in 'Bind / DNS / Nameserver Issues' started by eigh, Jan 19, 2006.

  1. eigh

    eigh Member

    Joined:
    Jul 25, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I have tried about 4 different things to make this work.

    I installed CentOS 4.2

    Then I installed the dnsonly version of cpanel.

    When I tried to go to the "Configure Cluster" section, I get a generic "This page cannot be displayed" MSIE error.

    I tried running

    Code:
    /scripts/upcp --force
    and halfway through the installation, I get infinite dots scrolling down my machine. To resolve this problem, I killed the realperlinstaller process while it was processing Net::AIM Net::SSLeay Archive

    Anyways, that allows upcp to run without error, but it doesn't actually resolve the problem. When I go to "COnfigure Cluster", I still do not get the cpanel cluster configuration interface.

    As per a suggestion on another forum thread, I ran

    Code:
    perl -MCPAN -e 'install Tie::IxHash;'
    but I am still unable to get to the clustering page.

    Anyone know what I need to do?
     
  2. Tagor

    Tagor Well-Known Member

    Joined:
    Mar 6, 2004
    Messages:
    193
    Likes Received:
    0
    Trophy Points:
    16
    Check your error_log to find out what causes the Microsoft error.
     
  3. eigh

    eigh Member

    Joined:
    Jul 25, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I did a tail -f /usr/local/cpanel/logs/error_log and then navigated to the page in question. Here is the output:


    Code:
    Can't locate Tie/IxHash.pm in @INC (@INC contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl . /usr/local/cpanel /usr/local/cpanel/whostmgr/docroot/cgi) at /usr/local/cpanel/whostmgr/docroot/cgi/parseform.pl line 6.
    BEGIN failed--compilation aborted at /usr/local/cpanel/whostmgr/docroot/cgi/parseform.pl line 6.
    Compilation failed in require at ./cgi/clusterstatus.cgi line 7.
    The error occurs at the line

    Code:
    use Tie::IxHash;
    Any Suggestions?

    Thanks,

    -- Jason
     
    #3 eigh, Jan 20, 2006
    Last edited: Jan 20, 2006
  4. eigh

    eigh Member

    Joined:
    Jul 25, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I tried running this again to see if it would resolve the problem.

    Code:
    perl -MCPAN -e 'install Tie::IxHash;'
    It didn't work. Here is the output:

    Code:
    root@lento [/etc]# perl -MCPAN -e 'install Tie::IxHash;'
    CPAN: Storable loaded ok
    Going to read /home/.cpan/Metadata
      Database was generated on Wed, 18 Jan 2006 04:11:56 GMT
    CPAN: LWP::UserAgent loaded ok
    Fetching with LWP:
      http://cpan.mirrors.hoobly.com/authors/01mailrc.txt.gz
    Going to read /home/.cpan/sources/authors/01mailrc.txt.gz
    Fetching with LWP:
      http://cpan.mirrors.hoobly.com/modules/02packages.details.txt.gz
    Going to read /home/.cpan/sources/modules/02packages.details.txt.gz
      Database was generated on Fri, 20 Jan 2006 03:10:33 GMT
    Fetching with LWP:
      http://cpan.mirrors.hoobly.com/modules/03modlist.data.gz
    Going to read /home/.cpan/sources/modules/03modlist.data.gz
    Going to write /home/.cpan/Metadata
    Running install for module Tie::IxHash
    Running make for G/GS/GSAR/Tie-IxHash-1.21.tar.gz
    CPAN: Digest::SHA loaded ok
    CPAN: Module::Signature loaded ok
    WARNING: This key is not certified with a trusted signature!
    Primary key fingerprint: 2E66 557A B97C 19C7 91AF  8E20 328D A867 450F 89EC
    Signature for /home/.cpan/sources/authors/id/G/GS/GSAR/CHECKSUMS ok
    Checksum for /home/.cpan/sources/authors/id/G/GS/GSAR/Tie-IxHash-1.21.tar.gz ok
    Scanning cache /home/.cpan/build for sizes
    Usage: Cwd::getcwd() at /usr/lib/perl5/5.8.5/File/Path.pm line 267.
    What should I do next?

    Thanks,

    -- Jason
     
    #4 eigh, Jan 20, 2006
    Last edited: Jan 20, 2006
  5. eigh

    eigh Member

    Joined:
    Jul 25, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    line 267 of /usr/lib/perl5/5.8.5/File/Path.pm is

    Code:
    my $oldpwd = &Cwd::getcwd;
    I'm assuming that that is causing the error installing Tie::IxHash

    There are two possible courses of action to fix this then.

    1) install Tie::IxHash without using perl -MCPAN -e
    2) fix perl -MCPAN -e so that it will install Tie::IxHash correctly.

    Does anyone know how I should proceed with this, and How? I have almost zero expierence with perl, so I'm kinda just relying 100% on community support here. Please help!

    Thanks,

    -- Jason
     
  6. Murtaza_t

    Murtaza_t Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    cPanel Access Level:
    Website Owner
    Have you tried installing the perl module with :

    /scripts/perlinstaller Tie::IxHash --force
     
  7. eigh

    eigh Member

    Joined:
    Jul 25, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    resolution

    Thanks for the suggestion, Murtaza_t.

    I dont doubt that that would have worked, but someone on another forum told me to install perl using

    Code:
    wget http://layer1.cpanel.net/perl587installer.tar.gz
    tar zxf perl587installer.tar.gz
    cd perl587installer
    ./install
    This fixed that problem.

    Thanks to everyone for your help!
     
Loading...

Share This Page