The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dnsonly install question

Discussion in 'Bind / DNS / Nameserver Issues' started by inteliport, Dec 1, 2006.

  1. inteliport

    inteliport Member

    Joined:
    Dec 31, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    How did you install dnsonly

    I like to know how some of you installed dnsonly software.

    Such as, what software is required on the server prior to the install of the dnsonly file.

    The reason I'm asking is I'm having a really hard time loading it on a fedrora core 5 system which is a clean system with no additional software added, such as apache, mysql, php, etc..

    I had assumed that the dnsonly download would install all required packages, based on the clean system comment in the brief install notes.

    This is not the case as it does not install all required packages.


    Thanks in advance :cool:
     
    #1 inteliport, Dec 1, 2006
    Last edited: Dec 1, 2006
  2. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    I have it running on a low spec FC2 VPS, took a bit of work to get stunnel to function correctly though and without stunnel the dns wont sync.

    As far as I am aware it does install everything it needs but stunnel is broken from the start (although I could be wrong as the VPS had plesk on it originally and I manually removed it)

    I got it running stable by trial and error so unfortunatly I cant be much help on providing steps to make it work but its perfectly pheasable to have running.
     
  3. purplepaws

    purplepaws Well-Known Member

    Joined:
    Jan 15, 2002
    Messages:
    153
    Likes Received:
    0
    Trophy Points:
    16
    Stunnel problems here too...

    Hi Guys,

    I'm having trouble with DNS Only on a CentOS 4.4 VPS. The install is OK, and I clustered the DNS machine from a primary cPanel box but the DNS isn't updating/synching

    Nick: If you don't know the steps you used to fix it, have you got any pointers regarding how to confirm its Stunnel related, and if so how to troubleshoot/test the stunnel installation?

    If I had actual error messages I'd have a better chance of fixing the problem, but at the moment the only thing that happens when I try to update/sync from the main box is I get the following appears in /var/log/secure on the DNS box:

    Dec 9 15:08:40 ns2 stunnel[1948]: whmhttps connected from 69.xx.xx.xx:55458
    Dec 9 15:08:40 ns2 stunnel[1948]: Connection closed: 88 bytes sent to SSL, 1188 bytes sent to socket


    Any pointers gratefully received!

    TIA,

    Rupert
     
  4. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    From what youve posted it looks as if stunnel is working correctly for you, as with my fc2 vps it wouldnt even start but yours is showing data throughput, so by the looks your issues are related to rndc and bind-libs, try running /scripts/upcp and /scripts/fixrndc
     
  5. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    purplepaws

    I'm lazy. When I install cPanel (DNSONLY or otherwise), I install only the developer tools and development libraries packages, removing all other package selections. This way I know 99.9% of the libraries are installed. Yeah, not the recommended way, but as I said, I'm lazy.

    Have you verified the DNS is functioning properly on the server? Also, is the other system present in the Cluster Configuration page?
     
  6. mitgib

    mitgib Well-Known Member
    PartnerNOC

    Joined:
    Apr 9, 2006
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    I just finished an install of DNSONLY in a Xen VM (FC6-x86_64) and other than the typical troubles with stunnel and the ssl cert, the only issue I had was the installed setup a cacheing nameserver, which after putting in a named.conf solved, clustered it with my other DNS server, syncronized all the zones, and working beatuflly in 256mb of ram.

    The only other issue I came across which was solved rather quickly was some perl modules csf wanted while compiling. So now that I've proven this concept to myself, time to tweak.
     
Loading...

Share This Page