freakin'me

Member
Jul 8, 2005
23
0
151
Hi,

I installed dns only on centos. The installation took 1171 minutes before I aborted it, all it did was printing dots on my screen, with a load on 0.0

Everything appears to work, however, there is no service that runs on port 2087 (the secure version), and therefor I am not able to cluster.

any ideas how i can also set up my ssl part correctly?

regards,

Freakin'me
 

Danny_T

Well-Known Member
Jul 19, 2005
181
0
166
Netherlands
I did had a tons of problems with the DNS-Only package.
Some bugs are solved in a a new version that I and a cpanel staff member did found.
cpanel staff did install the DNS-Only on 1 of my servers. It works great now.
But installing just from that sea package is not just working yet. I tried afterwards on a clean base install of a linux vmware box and it still wont install.
There are no depencies check done while installing.
It needs a lot perl modules and some other base tools that are not installed by the DNS-Only package during install.

So i guess you have the same problem.

About the ssl port, is the stunnel process running?

Danny.
 

freakin'me

Member
Jul 8, 2005
23
0
151
Thanks for your reply.

stunnel is installed, but does not appear to be running:
[email protected] [/scripts]# pidof stunnel

[email protected] [/scripts]# apt-get install stunnel
Reading Package Lists... Done
Building Dependency Tree... Done
stunnel is already the newest version.
0 upgraded, 0 newly installed, 0 removed and 6 not upgraded.
[email protected] [/scripts]# stunnel
2007.01.02 03:31:24 LOG3[26818:3086338272]: /etc/stunnel/stunnel.conf: No such file or directory (2)

Syntax:
stunnel [filename] | -fd [n] | -help | -version | -sockets
filename - use specified config file instead of /etc/stunnel/stunnel.conf
-fd n - read the config file from specified file descriptor
-help - get config file help
-version - display version and defaults
-sockets - display default socket options
[email protected] [/scripts]#
 

freakin'me

Member
Jul 8, 2005
23
0
151
I also found something about stunnel in logwatch:
--------------------- stunnel Begin ------------------------


**Unmatched Entries**
(6) stunnel 4.05 on i686-redhat-linux-gnu PTHREAD+LIBWRAP with OpenSSL 0.9.7a Feb 19 2003
(2) /usr/local/cpanel/etc/cpanel.pem: No such file or directory (2)
(4) FD_SETSIZE=1024, file ulimit=1024 -> 500 clients allowed
(4) Failed to get GID for group cpanel

---------------------- stunnel End -------------------------
Just for the record:
[email protected] [/scripts]# netstat -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 *:2086 *:* LISTEN
tcp 0 0 *:http *:* LISTEN
tcp 0 0 10.0.0.6:domain *:* LISTEN
tcp 0 0 10.0.0.5:domain *:* LISTEN
tcp 0 0 10.0.0.4:domain *:* LISTEN
tcp 0 0 ns3.hostdelight.net:domain *:* LISTEN
tcp 0 0 localhost:domain *:* LISTEN
tcp 0 0 *:ipp *:* LISTEN
tcp 0 0 localhost:rndc *:* LISTEN
tcp 0 0 localhost:smtp *:* LISTEN
tcp 0 0 *:https *:* LISTEN
tcp 0 0 *:ssh *:* LISTEN
udp 0 0 *:32776 *:*
udp 0 0 10.0.0.6:domain *:*
udp 0 0 10.0.0.5:domain *:*
udp 0 0 10.0.0.4:domain *:*
udp 0 0 ns3.hostdelight.net:domain *:*
udp 0 0 localhost:domain *:*
udp 0 0 *:ipp *:*
udp 0 0 *:32777 *:*
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ACC ] STREAM LISTENING 6172 /var/run/acpid.socket
unix 2 [ ACC ] STREAM LISTENING 6545 /var/run/dbus/system_bus_socket
[email protected] [/scripts]#