The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dnsOnly - stunnel and port 2087

Discussion in 'Bind / DNS / Nameserver Issues' started by internetfab, May 17, 2007.

  1. internetfab

    internetfab Well-Known Member
    PartnerNOC

    Joined:
    Feb 20, 2003
    Messages:
    336
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Gothenburg, Sweden
    cPanel Access Level:
    DataCenter Provider
    Hi,
    Had to reinstall one of our dns servers this night and ran into some problems with the dnsonly install - haven't used it in a year or two. It seems it has quite a few bugs right now, which may or may not be fixed with some tweaks here and there.

    I got bind working but I can't get stunnel to start up.. Whatever I do (i've read through most/all of the stunnel threads here already), it just refuses.. I've recompiled stunnel from cpanel sources (4.15) and symbolic linked it to /usr/bin/stunnel4.15local and /usr/sbin/stunnel and checked that stunnel isn't running and added it to the stopstunnel script.

    Running out of options - I logged a ticket with cPanel staff but am afraid I can't wait much longer..

    I've also added cpanel user manually since there wasnt one and stunnel was complaining about cpanel GID not found. I changed the cpanel root to /usr/local/cpanel

    This is the error from messages:
    May 18 06:27:40 dns1 stunnel: LOG5[3939:3086448864]: stunnel 4.15 on i686-pc-linux-gnu with OpenSSL 0.9.7a Feb 19 2003
    May 18 06:27:40 dns1 stunnel: LOG5[3939:3086448864]: Threading:PTHREAD SSL:ENGINE Sockets:POLL,IPv4 Auth:LIBWRAP
    May 18 06:27:40 dns1 stunnel: LOG5[3939:3086448864]: 500 clients allowed
    May 18 06:27:40 dns1 stunnel: LOG3[3952:3086448864]: chroot: No such file or directory (2)
     
  2. internetfab

    internetfab Well-Known Member
    PartnerNOC

    Joined:
    Feb 20, 2003
    Messages:
    336
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Gothenburg, Sweden
    cPanel Access Level:
    DataCenter Provider
    Solved..
    The directory it was looking for wasnt created.. /usr/local/cpanel/var/run/stunnel

    var/run/stunnel wasnt there.. none of em ;)
    And then I had to chown cpanel to em.. so stunnel could create a pid file.
     
Loading...

Share This Page