The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dnsreport error - Acceptance of domain literals

Discussion in 'Bind / DNS / Nameserver Issues' started by fuzzie, Mar 14, 2003.

  1. fuzzie

    fuzzie Well-Known Member

    Joined:
    Oct 12, 2002
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    After the update last night, I get this error on dnsreport.com under the MAIL heading:


    FAIL Acceptance of domain literals ERROR: One or more of your mailservers does not accept mail in the domain literal format (user@[0.0.0.0]). Mailservers are required RFC1123 5.2.17 to accept mail to domain literals for any of its IP addresses.

    domain.com's postmaster@[XXX.XXX.XXX.XXX] response:
    >>> RCPT TO: <postmaster@[XXX.XXX.XXX.XXX]>
    <<< 550-Host cpe-66-189-58-123.ma.charter.com (www.DNSreport.com) [66.189.58.123] is not permitted
    550-to relay through host.domain.com.
    550-Perhaps you have not logged into the pop/imap server in the last 30 minutes.
    550-You may also have been rejected because your ip address
    550-does not have a reverse DNS entry.
    550 relaying to prohibited by administrator


    Is this bad?
    I talked to at least one other Cpanel user who has the same problem.
    Chuck
     
  2. fuzzie

    fuzzie Well-Known Member

    Joined:
    Oct 12, 2002
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    This resolved itself last night with the update, thanks.
     
  3. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Not sure why you say that, Chuck? Error msg. still shows the same with DNSReport - same as mine. Apparently this is a Cpanel specific situation as I've checked on other sites and they do not show this error. Some say the error doesn't matter, but I'm not sure I would agree with them.
     
  4. SouthernWeb

    SouthernWeb Member

    Joined:
    Nov 8, 2001
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Birmingham, AL
    It is an EXIM config setting.

    Go to /etc/exim.conf and look for the following:

    # If you want to accept mail addressed to your host's literal IP address, for
    # example, mail addressed to "user@[111.111.111.111]", then uncomment the
    # following line, or supply the literal domain(s) as part of "local_domains"
    # above.

    # local_domains_include_host_literals

    Remove the # from #local_domains_include_host_literals and restart exim.
     
  5. fuzzie

    fuzzie Well-Known Member

    Joined:
    Oct 12, 2002
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Don't know why, but the error was gone, then it was back....

    But the above fixed it!

    Thanks a ton.
     
  6. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    I can only wonder why, DarkOrb decided to make this change for v6? As I use DNSReport quite frequently, I know this error was not showing up before. Hopefully they will provide an explaination or once again, follow RFC 1123 5.2.17 by default and save us having to manually change everytime.
     
  7. LordJMann

    LordJMann Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    I did the above but I got an error:

    Exim configuration error in line 124:
    main option "local_domains_include_host_literals" unknown

    All I did was remove the # from the front of it.

    From the result of that WHM news doesnt load and all services fail when the server is rebooted. Why isn't this option working?

    Code:
    # If you want to accept mail addressed to your host's literal IP address, for
    # example, mail addressed to "user@[111.111.111.111]", then uncomment the
    # following line, or supply the literal domain(s) as part of "local_domains"
    # above.
    
    local_domains_include_host_literals
    
     
  8. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    I use above step and i have error message when i restart exim :
    --------------------------------
    Dec 8 20:16:44 orange exim: exim shutdown failed Dec 8 20:16:45 orange exim: antirelayd shutdown failed Dec 8 20:16:45 orange exim: spamd shutdown failed Dec 8 20:16:46 orange exim: exim shutdown failed Dec 8 20:16:46 orange exim: antirelayd shutdown failed Dec 8 20:16:46 orange exim: spamd shutdown failed Dec 8 20:16:47 orange exim: exim shutdown failed Dec 8 20:16:47 orange exim: antirelayd shutdown failed Dec 8 20:16:47 orange exim: spamd shutdown failed Dec 8 20:16:48 orange exim: 2003-12-08 20:16:48 Exim configuration error in line 127: Dec 8 20:16:48 orange exim: main option "local_domains_include_host_literals" unknown Dec 8 20:16:48 orange exim: exim startup failed Dec 8 20:16:48 orange exim: exim startup succeeded Dec 8 20:16:48 orange exim: 2003-12-08 20:16:48 Exim configuration error in line 127: Dec 8 20:16:48 orange exim: main option "local_domains_include_host_literals" unknown Dec 8 20:16:48 orange exim: exim startup failed Dec 8 20:16:49 orange exim: antirelayd startup succeeded Dec 8 20:16:53 orange exim: spamd startup failed exim has failed, please contact the sysadmin.
    -------------------------

    Why ??? :confused:
     
  9. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    Same error here.....anyone ever figure it out?

    Damion
     
  10. webdave

    webdave Active Member

    Joined:
    Jul 4, 2002
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Bump. I am getting this same error.
     
  11. LordJMann

    LordJMann Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    I'm getting the same error these guys have been getting, and I haven't got it to work for 3 months!
     
  12. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    any solution with this error ?
     
  13. MADLaker

    MADLaker Registered

    Joined:
    Feb 3, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chicago
    #13 MADLaker, Apr 14, 2004
    Last edited: Apr 14, 2004
  14. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Did you try my suggestion in that thread? It worked fine for me and others.
     
  15. LordJMann

    LordJMann Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    That worked just great! Exim should update their config.
     
  16. Sabaote

    Sabaote Well-Known Member

    Joined:
    Dec 19, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ribeirao Preto, Brazil
    Please, someone could explain for me...
    What is the advantage of this?

    Of allow literal domains ?

    Thanks you!!
     
  17. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
Loading...

Share This Page