/docroot/cgi/cpaddons_report.pl --notify

bartek

Member
Dec 19, 2003
14
0
151
I just got this via cron - I suppose an auto-update screwed something up?


Global symbol "$owner" requires explicit package name at /usr/local/cpanel/whostmgr/docroot/cgi/cpaddons_report.pl line 405.
Global symbol "$owner" requires explicit package name at /usr/local/cpanel/whostmgr/docroot/cgi/cpaddons_report.pl line 406.
Execution of /usr/local/cpanel/whostmgr/docroot/cgi/cpaddons_report.pl aborted due to compilation errors.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
308
cPanel Access Level
Root Administrator
Thanks. I've notified the developers of this issue. I think commenting out lines 404 to 410 should resolve it. Make those lines look like:
Code:
#            if ( $notify_root
#               && ( $owner ne 'root'
#                    || ( $owner eq 'root' && !$notify_owner ) ) )
#            {
#
#                # TODO              send email to root, case 3259
#            }
This should be fixed in the next build.
 

cPDan

cPanel Staff
Staff member
Mar 9, 2004
721
13
243
Affects last nights EDGE and CURRENT, will be fixed in next builds.
 

gtgeorge

Well-Known Member
Feb 28, 2007
86
0
156
Affects last nights EDGE and CURRENT, will be fixed in next builds.
Thanks for the update as we just received the same error last night before the upcp ran.