Does 84.0.17 Update will force you to update MySQL?

froi-manila

Member
Jan 11, 2014
10
0
1
Philippines
cPanel Access Level
Reseller Owner
Is this build will forcibly update MySQL to 5.7?? We have a server that we know is under 5.6 but has been updated to 5.7. it broke a system hosted on that server. Our cPanel server's update preference is set to automatic but, as far as we know, MySQL will not auto-update.

We need to know, so we could adjust other server's update preference.

Thanks
 
Last edited by a moderator:

quietFinn

Well-Known Member
Feb 4, 2006
1,155
63
178
Finland
cPanel Access Level
Root Administrator
cPanel/WHM update will never update server's MySQL/MariaDB. If the update would require a certain MySQL/MariaDB version it would be an "update blocker".
 

cPJeremy

Technical Analyst
Staff member
Feb 13, 2019
38
2
83
Houston TX
cPanel Access Level
Root Administrator
Hello, froi-manila!

At this time I just wished to mention that quietFinn is correct. Updating cPanel & WHM to a new version will not automatically update your MySQL or MariaDB version. If you were required to update your MySQL or MariaDB version for any reason, you would be warned and would be blocked from updating to a newer version of cPanel.

Thank you!
 

quietFinn

Well-Known Member
Feb 4, 2006
1,155
63
178
Finland
cPanel Access Level
Root Administrator
Maybe I need to clarify a few things (for myself also):
As I said cPanel/WHM update does not automatically update MySQL or MariaDB version.
But if you go to WHM -> Server Configuration -> Update Preferences there is another setting for Operating System Packages.
If you have that set to Automatic, if will also update MySQL/MaridDB, but only the minor version, i.e. if you have MySQL version 5.7.xx it will be updated to MySQL 5.7.yy. It will not update the major version, for ex. from 5.6 to 5.7.