Does cPanel with LiteSpeed on CloudLinux support PHP-FPM?

GrAlex

Member
Mar 2, 2017
6
1
3
NSK
cPanel Access Level
Root Administrator
Hello,

Just wondering does cPanel+LiteSpeed on CloudLinux support PHP-FPM?

Logged as root in cPanel, and on a page "Set PHP Version per Domain" I've set PHP Version to ea-php56 and PHP-FPM is ON for a specific domain. And still phpinfo() under the domain shows: Server API LiteSpeed V6.10.

Why do I need it? Well, let it stay out of the scope, please. I really need to know whether or not it's possible. And if it is yes, then please let what do I miss and how to set it up.

Regards,
Alex.
 

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
807
158
168
New Jersey
cPanel Access Level
DataCenter Provider
  • Like
Reactions: GrAlex

GrAlex

Member
Mar 2, 2017
6
1
3
NSK
cPanel Access Level
Root Administrator
Thanks for the link. It seems Google hid the page from me. One question is now answered, that's good.

Now I'd like to know whom should I address the question on why PHP-FPM selected in cPanel is not activated for my domain?

I see a FPM pool is created, the config files exists in /opt/cpanel/ea-php56/root/etc/php-fpm.d/ and socket is ready /opt/cpanel/ea-php56/root/usr/var/run/php-fpm/94d49cf160dc86bb345671f4a1c956d336aad50f.sock, but still LiteSpeed ignores chosen PHP-mode and still handles all the requests via lsphp.

Is it an issue of cPanel or LiteSpeed. CloudLinux as it seems does not support PHP-FPM as of now.
 

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
807
158
168
New Jersey
cPanel Access Level
DataCenter Provider
I cannot find any documentation on it, you would most likely be better off just disabling LiteSpeed all together and use Apache with PHP-FPM otherwise I would post on LiteSpeed's forums.
 
  • Like
Reactions: GrAlex

GrAlex

Member
Mar 2, 2017
6
1
3
NSK
cPanel Access Level
Root Administrator
Found out that it's CloudLinux which changes the PHP mode:

# selectorctl --user-current --user=user
5.6 5.6.30 /opt/alt/php56/usr/bin/php-cgi

But it stops working if I set it to native even with ea-php56 (PHP-FPM OFF) in cPanel. Stops working here means the following a PHP script in a browser returns 0-size page with HTTP 200, OK.

Could you please let me know what might be wrong?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Could you please let me know what might be wrong?
Hello,

Could you open a support ticket using the link in my signature so we can take a closer look at your system to see what's happening? You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
I've opened a ticket. Support Request ID is: 8282149. No access is provided. So I guess you won't help to resolve it.
Hello,

You could send a reply to the ticket to explain that you prefer to not provide access, but it's generally easier for us to troubleshoot an issue with access to the affected system.

Thank you.
 

Anoop P Alias

Well-Known Member
Mar 31, 2015
103
16
18
Kochi,Kerala,India
cPanel Access Level
Root Administrator
Apache => mod_proxy_fcgi => php-fpm
Apache=>mod_lsapi(CloudLinux) => lsphp
Litespeed =>lsapi => lsphp

This is how it works. FastCGI and LSAPI are protocols . I think its better to stick with lsapi/lsphp if using LiteSpeed as LiteSpeed is mostly used and tested to run php this way